Tub spout still drips after valve + seat replacement

Users who are viewing this thread

Neil.Steiner

Member
Messages
35
Reaction score
0
Points
6
Location
Virginia
An older 3-handle shower of mine developed a problem where even when the faucets are turned off, the spout would still drip a little, and I had to turn the faucets really tight to get the dripping to stop. My wife tells me the problem is mostly with the hot water faucet.

I hired a plumber for something else, and asked him to replace the valve stems on this shower. I figured he would replace the valve stems and seats, but he only replaced the bib gaskets, and after he was done, I still had to turn the faucet really hard to get the dripping to stop. I explained the situation, but he said he had performed the service correctly.

I figured the plumber just wasn't as thorough as he should have been, so I replaced the valve stems and seats myself. It was my first time working on something inside the walls, but I think I did everything correctly. I used Rectorseal 5 on the seat threads. I tightened everything else somewhere between snug and tight, with the possible exception of the bib washers which I didn't tighten especially hard.

When I turned the water main back on, with the faucets off, it took a little while, but the spout again started dripping a little. In fact, it's dripping more than it was before or after the plumber. I can tighten the faucets really hard (not sure how much is safe), but the dripping continues. I see no evidence of any leaks from the side or center of the stems.

Which makes me wonder, could the alignment between the valve and seat be a little off? I don't think anything is cross-threaded—and wouldn't I get a leak on the side of the stem if it were?—but I'm unsure how to explain what might be happening here. The old hot water seat wasn't perfect, but it didn't look like it could have caused this problem.

Any thoughts or suggestions would be much appreciated.
 

Terry

The Plumbing Wizard
Staff member
Messages
29,311
Reaction score
3,089
Points
113
Location
Bothell, Washington
Website
terrylove.com
It sounds like you did well. I'm sorry. I have had a time or two when the old three handle wasn't being cooperative too.
Sometimes it's nice to start over with a new single handle.

gibson-02.jpg


gibson-03.jpg


The trim with handle is the Moen TL2368EP and their Posi-Temp valve
The spout is a Delta.
 

Jeff H Young

In the Trades
Messages
5,435
Reaction score
1,201
Points
113
Location
92346
An older 3-handle shower of mine developed a problem where even when the faucets are turned off, the spout would still drip a little, and I had to turn the faucets really tight to get the dripping to stop. My wife tells me the problem is mostly with the hot water faucet.

I hired a plumber for something else, and asked him to replace the valve stems on this shower. I figured he would replace the valve stems and seats, but he only replaced the bib gaskets, and after he was done, I still had to turn the faucet really hard to get the dripping to stop. I explained the situation, but he said he had performed the service correctly.

I figured the plumber just wasn't as thorough as he should have been, so I replaced the valve stems and seats myself. It was my first time working on something inside the walls, but I think I did everything correctly. I used Rectorseal 5 on the seat threads. I tightened everything else somewhere between snug and tight, with the possible exception of the bib washers which I didn't tighten especially hard.

When I turned the water main back on, with the faucets off, it took a little while, but the spout again started dripping a little. In fact, it's dripping more than it was before or after the plumber. I can tighten the faucets really hard (not sure how much is safe), but the dripping continues. I see no evidence of any leaks from the side or center of the stems.

Which makes me wonder, could the alignment between the valve and seat be a little off? I don't think anything is cross-threaded—and wouldn't I get a leak on the side of the stem if it were?—but I'm unsure how to explain what might be happening here. The old hot water seat wasn't perfect, but it didn't look like it could have caused this problem.

Any thoughts or suggestions would be much appreciated.

So you got 2 choices figure out and hopefully fix or replace entire valve. As you can tell this is real primative stuff..... so its possible somehow the seat metal to metal contact with the valve body is at fault , is there any differance bettween new seats and old? buy the same seats from another source might work. replace washers on your new stem or flip over. there isnt a wholelot more to do but maybe you can find something wrong or damaged. Ive never come up with a way to seal of the seat to the valve body or found one that was defective in that area that I remember. new seats no going all the way in ? hope you find out problem and dont have to give up
 

jadnashua

Retired Defense Industry Engineer xxx
Messages
32,736
Reaction score
1,163
Points
113
Location
New England
A few things, the stem might not be the correct length, the seat is incorrect for the stem and the valve body, the washer may not be the right size (diameter or thickness) or is damaged, if the stem has a notch for the washer's edges, and isn't the right size, it can warp the washer, the valve body has an erosion hole or crack in it.
 

Jeff H Young

In the Trades
Messages
5,435
Reaction score
1,201
Points
113
Location
92346
A few things, the stem might not be the correct length, the seat is incorrect for the stem and the valve body, the washer may not be the right size (diameter or thickness) or is damaged, if the stem has a notch for the washer's edges, and isn't the right size, it can warp the washer, the valve body has an erosion hole or crack in it.
all true it can be hard to figure out but gotta walk through everything a few times or like i said replace whole valve
 

Neil.Steiner

Member
Messages
35
Reaction score
0
Points
6
Location
Virginia
Thank you, one and all, and thanks especially to Jeff H Young for suggesting that I try buying the seats from another source. I purchased OEM seats, instead of the seats that came with the repair kit. I also saw something that reminded me of what members of this forum have suggested in the past: That I put teflon tape on the [seat] threads, and put pipe dope over the tape. I've got no more dripping, so it appears my problem is resolved.

Note that I still have no idea how the dripping started. There had been no work done on those faucets for almost a decade, and if the problem had come from worn bib washers, that problem should have gone away when the plumber replaced those washers. It remains a bit of a puzzler.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks