Problem with Kohler Cimmaron Toilet

Discussion in 'Toilet Forum discussions' started by tlong_66, Nov 6, 2009.

  1. tlong_66

    tlong_66 New Member

    Joined:
    Apr 7, 2008
    I've had a Kohler Cimmaron for a year or so now and it has worked great until recently. Every few minutes the fill valve opens and fills the tank then somehow it must lose water because it kicks on awhile later. I have tried adusting the chain and water level and cleaning around flapper seal. Any other ideas or do i need to install new fil valve and/or flush valve? I don't use any in tank cleaning by the way. Also will it accept a universal repair valve?
     
    Last edited: Nov 6, 2009
  2. Artie

    Artie New Member

    Joined:
    Nov 6, 2009
    Location:
    Jacksonville, Fl
    It sounds like the fill valve is working as its supposed to. Do you have a shut-off valve under the toilet tank? If so, just turn it off, and check back in a couple hours. If the water level is down, you have a leak. Probably the flapper valve. Only takes a tiny bit of grit of something to cause it to leak. Or just being worn out.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. Terry

    Terry Administrator Staff Member

    Joined:
    Aug 17, 2004
    Occupation:
    Plumber
    Location:
    Bothell, Washington
    Sounds like a flapper gone bad.
    They sell the Cimarron flapper in hardware stores.
     
Similar Threads: Problem Kohler
Forum Title Date
Toilet Forum discussions Problem with Kohler toilet Feb 20, 2021
Toilet Forum discussions Kohler toilet flushing problem on San Raphael one-piece Jan 12, 2014
Toilet Forum discussions Kohler Persuade Flush Problem (Brand new toilet) Dec 4, 2011
Toilet Forum discussions Kohler Wellworth problem Dec 13, 2010
Toilet Forum discussions Kohler Class 5 problem Feb 7, 2009

Share This Page