Pump troubleshooting

Users who are viewing this thread

misterkel

New Member
Messages
2
Reaction score
1
Points
3
Location
Nova Scotia
I am trying to diagnose why my dug well won't pressure up.
Here are the symptoms.
There is sufficient water (about 2/3 up the submersible casing).
When I turn on the breaker, water comes out for about 1 minute or so.
Never get full pressure.
Stops within a minute, maybe a few seconds.
Switch seems fine. Is indoors, has no rust, no leaking, etc. Appears brand new, is closed, but can be opened and closed with ease.
Whole system is high quality, installed new 4 years ago. Receives daily residential usage.

Pump has a sock - could it be clogged?
Is there some kind of short at the well?
How to check for issues?
 

Bannerman

Well-Known Member
Messages
4,939
Reaction score
831
Points
113
Location
Ontario, Canada
Pump details? (HP, model number etc)
Well details? (Depth of well, static water depth, pump depth, diameter of well casing, well casing material)
Voltage supplied to pump?
Using a clamp-on amp meter, Amps drawn by the pump during the initial 1-minute of water delivery, and amps drawn once water delivery stops?
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks