Softener not syphoning brine

Users who are viewing this thread

Going North

New Member
Messages
2
Reaction score
1
Points
3
Location
Michigan
I have a 10 year old GE480, model# 625-388-480 that is not syphoning brine. I’ve taken everything apart on the brine valve assembly, inspected and cleaned lines, valves, & screens. I even replaced the venturi valve assembly. I confirmed the brine line is not plugged, there is a small screen inside the line at the venturi connection. I even blew high pressure air through the line from the venturi end to confirm screen (in line) is not blocked and to try to dislodge anything in the line. I can blow though the line easily by mouth. The venturi is strong enough to syphon fresh water from a 5 gallon bucket but not strong enough to siphon salt water. I even ran a bottle of "Ironout" through the softener from the 5 gallon bucket. I removed 98 percent of the salt and water, and even removed the 4” brine valve assembly tube and cleaned bottom of brine tank. There was some salt slug left that I could not get that mostly dissolved when trying to test “brine” cycle. It fills the brine tank correctly. It acts like there is not enough vacuum to draw the brine. I'm out of ideas. Any suggestions before I purchase a new softener?.
 

Reach4

Well-Known Member
Messages
39,050
Reaction score
4,490
Points
113
Location
IL
I cannot find information on that softener.

City water or well? Sounds irrelevant, but softener resin lasts longer with well water usually. So you could give points to a new softener in that that includes new resin. If you get a softener for city water, be sure it comes with 10% crosslinked resin.

Is there an injector screen that you cleaned?

Can you measure the drain flow during the brine draw cycle? The softeners I have service manuals that show what the expected flow is for a given injector.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks