How to troubleshoot brine line drawing air

Discussion in 'Water Softener Forum, Questions and Answers' started by ransonjd, Feb 14, 2020 at 8:20 PM.

  1. ransonjd

    ransonjd Member

    Joined:
    Jan 22, 2017
    Location:
    New York
    I have a 2 Cu. Ft. softener with a Fleck 5810XTR2. I've noted that the brine line seems to be drawing air once the brine tank empties during the draw cycle. From reading elsewhere this sounds like a check valve issue or brine line leak. I've seen suggestions for how to troubleshoot, but I'm not clear on how to do it with my brine tank setup. Can I get some pointers?

    IMG_20200214_230458.jpg

    IMG_20200214_230605.jpg
     
  2. ditttohead

    ditttohead Water systems designer, R&D

    Joined:
    Jan 9, 2012
    Occupation:
    Water systems designer, R&D, Technical Director
    Location:
    Ontario California
    Take the brine line fitting at the valve apart and make sure the Jaco fitting is assembled correctly. Remove the brine line from the Legris fitting in the brine tank, cut the tube short 1" and reinsert into the brine safety float assembly.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. ransonjd

    ransonjd Member

    Joined:
    Jan 22, 2017
    Location:
    New York
    The Legris fitting was easy to cut and reconnect. I'm a little more concerned about the Jaco fitting. Does it look correct? I'm concerned that the compression marks all seem to be past the tube support, and the tube support appears to be corroding.

    IMG_20200215_225217.jpg
    IMG_20200215_225241.jpg
    IMG_20200215_225250.jpg
    IMG_20200215_225257.jpg
     
  5. ditttohead

    ditttohead Water systems designer, R&D

    Joined:
    Jan 9, 2012
    Occupation:
    Water systems designer, R&D, Technical Director
    Location:
    Ontario California
    Jaco fitting is installed correctly. I would remove the tube insert, cut the tube back an inch and reinsert and tighten it.
     
  6. ransonjd

    ransonjd Member

    Joined:
    Jan 22, 2017
    Location:
    New York
    Okay, I've cut and reassembled both ends of the tube. I've got a while before the system needs to regenerate, so I'll get back to this in a few days.
     
  7. Bannerman

    Bannerman Well-Known Member

    Joined:
    Mar 19, 2014
    Location:
    Ontario, Canada
    If you wish to verify without waiting days for an automatic regeneration cycle, simply perform a manual regeneration cycle to suit your availability.
     
  8. ditttohead

    ditttohead Water systems designer, R&D

    Joined:
    Jan 9, 2012
    Occupation:
    Water systems designer, R&D, Technical Director
    Location:
    Ontario California
    To test brine line integrity simply put the system in refill and lift up the safety float in the brine tank. This will pressure test everything except for the parts after the float.
     
Similar Threads: troubleshoot brine
Forum Title Date
Water Softener Forum, Questions and Answers Fleck5600SXT with Carbon Upflow Troubleshooting Jul 31, 2019
Water Softener Forum, Questions and Answers How to Troubleshoot AutoTrol 460i controller Dec 7, 2018
Water Softener Forum, Questions and Answers How old is too old, and troubleshooting before replacing? Apr 9, 2018
Water Softener Forum, Questions and Answers Troubleshooting a Fleck 5600 Mar 17, 2017
Water Softener Forum, Questions and Answers Troubleshooting 2900s valve Dec 3, 2016

Share This Page