No Soft Water

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by sbcoach, May 5, 2007.

  1. sbcoach

    sbcoach New Member

    Joined:
    May 3, 2007
    I have a Kenmore water softener that was run out of salt. Not a new thing. This time after refilling the salt and regenerating a few days there still is no soft water. Everything seems to be working correctly in the regeneration cycle but still no soft water. Ideas??
     
  2. kordts

    kordts In the Trades

    Joined:
    Oct 15, 2005
    Occupation:
    industrial service plumbing foreman
    Location:
    exurban Chicago
    Call Sears, if it's still under warranty. I myself use an independant treatment guy to test water and design the systems. Your salt setting may be too low. It may need to be set to regenerate more often.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. SteveW

    SteveW DIY Senior Member

    Joined:
    Feb 11, 2005
    Location:
    Omaha, NE
    You probably have a water heater full of hard water. It will take a while to refill with soft water.
     
  5. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    Is the water in the brine tank higher than normal?

    Is there water running to drain in a regeneration?

    Check the operation and troubleshooting sections here:
    www.kenmorewater.com.
     
Similar Threads: Soft Water
Forum Title Date
Plumbing Forum, Professional & DIY Advice Install new water softener loop May 24, 2017
Plumbing Forum, Professional & DIY Advice Hard hard water, softner installed. Apr 15, 2017
Plumbing Forum, Professional & DIY Advice Size of drainpipe for washer and water softener Apr 3, 2017
Plumbing Forum, Professional & DIY Advice Water softener problem after power outage Mar 14, 2017
Plumbing Forum, Professional & DIY Advice Water softener Radiant heating question Mar 6, 2017

Share This Page