Help, my oil burner is not working

Discussion in 'HVAC Heating & Cooling' started by paulmars, Dec 3, 2019.

  1. paulmars

    paulmars Member

    Joined:
    Aug 26, 2010
    Location:
    Florida
    Oil burner pump is not pulling in fuel. This is a single line system and beckett says that I should feel vacuum at pump inlet with the bleed port opened but I don't. The pump strainer is clean. Any ideas what could be wrong and how to test?

    Additional info: Yesterday, I closed the oil line shutoff valve (located 20 feet away at the oil tank) to change the oil filter. After changing it, I forgot to open the shutoff valve. I turned on my heater and it stopped after a minute or so. It does that if there is excessive air in the line (from changing the filter). So, i did what I always do, I pressed the manual red reset button to reset safety switch on the Honeywell R8184G Oil Primary Control. At that point the heater fires back up and I open the bleed port on the Beckett AFG pump and a mixture of air and fuel comes out. I do that until just fuel comes out, then I tighten it and enjoy warmth coming from my vents. It is wonderful. Except this time the Honeywell red safety switch tripped again (sometimes that happens, so I just press it again and open the bleed port again as indicated above). Well this second time and a 3rd and 4th time, I never again got a solid stream of fuel, just a mixture of fuel and air. Then I remembered that I never opened the oil line shutoff valve, so I did that. After that nothing comes out the bleed port on the Beckett pump. I tried that three times, each time until the Honeywell red safety switch tripped. I thought I maybe broke something trying to use my heater with the oil line shutoff valve closed. However, just now reading the Honeywell R8184G Oil Primary Control instructions, it instructs "safety check feature simulate flame failure" to close the oil line shutoff valve and make sure the unit shuts down, then to press the red reset safety switch on the Honeywell R8184G Oil Primary Control. Which I did, but I still get no fuel to the beckett (as listed above).

    I have used the heater a few times in the past 2 weeks before I changed the filter (as listed above), and it worked fine. I also checked the new filter install and everything looks good and made sure I got flow thru the filter and checked the entire line oil tank to Beckett is unobstructed.

    I just removed the inlet oil supply line where it attaches to the Beckett pump (suntek) and fired her up. I feel no vacuum at the pump inlet. So, I asked beckett and see 1st paragraph above.

    Any ideas as to what might be wrong and how to test?

    tks,
    paul
     
Similar Threads: Help burner
Forum Title Date
HVAC Heating & Cooling Help with Hydronic Heating- main burners not kicking on Apr 1, 2009
HVAC Heating & Cooling Heating and cooling a condo with interior rooms and lack of options! Help! Apr 26, 2021
HVAC Heating & Cooling Help Relocating Supply Plenum in Remodel Apr 19, 2021
HVAC Heating & Cooling Help- Transitioning from duct board trunk to metal Apr 16, 2021
HVAC Heating & Cooling Old contactor different than new contactor wiring help Apr 10, 2021

Share This Page