Shower: no hot water, leaking

Users who are viewing this thread

Mstro8

New Member
Messages
1
Reaction score
0
Points
1
Location
Pennsylvania
I have an old two-valve shower (no tub) that leaks cold water and no hot water comes out when I turn the hot handle.

Bought the house a year ago and the shower head leaked. It’s an old American Standard Aquaseal style (pics attached). I replaced the hot and cold valve stems and it worked for a month. Now, no water will come out when I turn the hot handle and the shower is slowly leaking again. Cold water still comes out. The sink is on the same pipe and the hot water works fine.

Is there a mixing valve somewhere that I’m missing? I don’t see anything behind the wall (pics attached). I took the valve stems out to inspect and they look fine. Any thoughts? Thanks so much!
 

Attachments

  • IMG_8679.png
    IMG_8679.png
    102.1 KB · Views: 51
  • IMG_8678.png
    IMG_8678.png
    89.6 KB · Views: 51
  • IMG_8677.jpeg
    IMG_8677.jpeg
    18.1 KB · Views: 47
  • IMG_8680.jpeg
    IMG_8680.jpeg
    137 KB · Views: 50
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks