New Rheem Tankless Issue

Discussion in 'Tankless Water Heater Forum' started by Jemmypaeg, Jan 21, 2020.

  1. Jemmypaeg

    Jemmypaeg New Member

    Joined:
    Jan 21, 2020
    Location:
    Kelowna
    Hello, I recently had a Rheem EcoH200DVLN-2 installed by a professional plumber/gas fitter, the only portion I did myself was run the PVC for the venting and had him verify it's correct. I purchased the unit separately. After about a week it started throwing an error code 10 as soon as any tap is turned on, which is supposed to indicate an issue with venting.

    I used 2" CPVC on the exhaust and 2" PVC on the intake, both runs are within 1' of each other in length, there are 2 90s and then a straight 30' horizontal run outside the home. Dipswitches are set correctly for longer 2" runs and is good up to 45' with 5 90s. I've reset it a few times with no change.

    The unit has no issues running, and is moving a lot of air, you can feel it blowing strongly at the side of the home. I contacted Rheem and they're sending me a new blower motor, but I have my doubts if that will fix the issue as this one is running.

    Any ideas or things I can do to troubleshoot further?

    Thanks in advance.
     
Similar Threads: Rheem Tankless
Forum Title Date
Tankless Water Heater Forum Scratching head - Rheem rtgh-95dvln tankless making 'whomp' noise on startupp Apr 6, 2020
Tankless Water Heater Forum My experience with Rheem RTGH-95XLP tankless WH Feb 23, 2020
Tankless Water Heater Forum Decibel rating from AO Smith/Rheem/Takagi Tankless Dec 4, 2019
Tankless Water Heater Forum Startup of PEX radiant heat with a Rheem eco tankless heater Sep 21, 2019
Tankless Water Heater Forum Rheem tankless water heater, unusual behaviour Jul 21, 2019

Share This Page