Dripping Delta Shower head, cartridge (RP46074) for 13/14 series replaced and still drips

Users who are viewing this thread

Endless Motion

New Member
Messages
3
Reaction score
0
Points
1
Location
Arizona
Our Delta shower head started dripping after being shut off and would not stop. Its a 13/14 series and takes the RP46074 cartridge which is just coming up on five years since the home was built. I purchased another Delta RP46074 cartridge and replaced the old one. After turning off the valve, the drip continues without stopping, though not as much as before. I noticed if I add 2 lbs pressure on the valve handle, the dripping stops. I currently have a 2 lb weight suspended on the handle to prevent wasting water. Any ideas what I may have done wrong or suggestions what I might do next? The installation seemed pretty straight forward and all clicked into place like the Delta instruction video showed. I also lubed up the three O rings on the replacement valve before installing with the recommended O ring lubricant.

delta-rp46074.jpg
 

Endless Motion

New Member
Messages
3
Reaction score
0
Points
1
Location
Arizona
Where did you get the cartridge?
I bought it at Home Depot. They sell the original DELTA cartridges. I also bought a DANCO aftermarket cartridge that I left as a back-up just to try a different manufacturer in case I still have a problem with the DELTA cartridge. I'm about to pull it out and re-install the DELTA again. The drip has reduced significantly, but still drips... :-(
 

Endless Motion

New Member
Messages
3
Reaction score
0
Points
1
Location
Arizona
Suggest contacting Delta as I understand there is a lifetime warranty for the original owner.
Thanks. I did. They sent me some suggestions, which I have tried. I'm going through the suggested route a third time too see if it finally cures the problem...
 

John Gayewski

In the Trades
Messages
2,442
Reaction score
630
Points
113
Location
Iowa
Thanks. I did. They sent me some suggestions, which I have tried. I'm going through the suggested route a third time too see if it finally cures the problem...
I think you should try a thorough Flushing. Sounds to me like gunk in the line.
 

Bricbasher

New Member
Messages
1
Reaction score
0
Points
1
Location
Georgia
Thanks. I did. They sent me some suggestions, which I have tried. I'm going through the suggested route a third time too see if it finally cures the problem...
Were you able to resolve this? I have the exact same issue occurring. Same cartridge and all. I haven't hung a weight from the handle but if I hold pressure on it the dripping stops.

Edit: I've been looking around on the interweb and I have seen where people have been checking the valve (I hope that's the right term) itself to make sure there isn't any calcium or mineral buildup. I am going to make sure and clean the valve with some baking soda to remove any buildup. I know I have hard water and although we have a water softener I will check and see if this is my problem and report back.
 
Last edited:
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks