Clack WS1 (hissing sound and no soft water)

Discussion in 'Water Softener Forum, Questions and Answers' started by cyclism, Feb 17, 2020.

  1. cyclism

    cyclism New Member

    Joined:
    Feb 17, 2020
    Location:
    Jax, FL
    I've had this system now for about 10 years and had the resin redone once about 2 years ago. I cleaned the injector, it wasn't clogged, but checked for the pin hole. The hissing sound only occurs when the valves are open, if I close off the system it goes away. Water does not seem to get any lower in the brine tank, get's to an overflow outlet and I up up draining it sometimes, however this is not always the case. It just never gets lower like it did the first 9 years or so. I'm not really sure what to check at this point. Hard for me to tell exactly where the hiss comes from, definitely near the control head area. This has been going on for a few months now.
     
  2. Bannerman

    Bannerman Well-Known Member

    Joined:
    Mar 19, 2014
    Location:
    Ontario, Canada
    Sounds like it maybe a leak to drain. It also sounds as though the brine is not being drawn, but is refilling at the end of each regeneration cycle.

    While you stated the resin was replaced 2 years ago, you didn't mention if the valve was also serviced. From your description, it sounds like the seal and spacer stack may need to be replaced, possibly including the piston.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. ditttohead

    ditttohead Water systems designer, R&D

    Joined:
    Jan 9, 2012
    Occupation:
    Water systems designer, R&D, Technical Director
    Location:
    Ontario California
    10 years old, do a complete valve rebuild, the system will basically be new.

     
Similar Threads: Clack (hissing
Forum Title Date
Water Softener Forum, Questions and Answers Clack WS1CS settings after hardness test Mar 15, 2020
Water Softener Forum, Questions and Answers Clack WS EA help with settings Mar 5, 2020
Water Softener Forum, Questions and Answers Clack WS1-CS need help programing Feb 17, 2020
Water Softener Forum, Questions and Answers Clack WS-1 is filling brine tank when it should be drawing brine - FIXED! Feb 14, 2020
Water Softener Forum, Questions and Answers Clack WS1 not pulling brine Jan 8, 2020

Share This Page