Submersible pump quit

Discussion in 'Pumps and Tanks Well Forum & Blog. Water is life.' started by itsmeboat, Aug 9, 2011.

  1. itsmeboat

    itsmeboat New Member

    Joined:
    Aug 9, 2011
    Location:
    HARTWELL, GA.
    I use my 800' deep well for watering now that we have county water. It quit yesterday after several hours. In checking
    the control box (Pentek, 1 hp, 230 v) I could see the capacitor was leaking and was hot. Bought a new controller today $70
    and installed. R-B-Y all attached properly to leads. 230 feed from crawl space 12 gauge/ blk,wht,grn attached to L1 and L2 as before and
    ground to box ground nut. Turned on breaker.....a loud pop, black smoke. and main breaker and disconnect pull tripped. Box was hot
    and bottom blew out of capacitor.....what's up. Thanks.
     
  2. lockewell

    lockewell New Member

    Joined:
    Aug 10, 2011
    Location:
    Orlando, FL
    I would say you have either bad pump wire or a bad pump motor.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Submersible pump
Forum Title Date
Pumps and Tanks Well Forum & Blog. Water is life. Submersible Pump Feb 11, 2017
Pumps and Tanks Well Forum & Blog. Water is life. Have a F&W submersible pump seems to have stopped, replaced QB control box Jan 30, 2017
Pumps and Tanks Well Forum & Blog. Water is life. Am I getting ripped off on a submersible pump? Jan 25, 2017
Pumps and Tanks Well Forum & Blog. Water is life. Submersible pump problems Jan 11, 2017
Pumps and Tanks Well Forum & Blog. Water is life. HELP PLEASE.. New submersible well pump clogging lines with shell fragments Dec 26, 2016

Share This Page