NPE-180A2 does not seem to be circulating correctly through Navicirc

Users who are viewing this thread

coolgreany

New Member
Messages
9
Reaction score
0
Points
1
Location
Florida
I've looked at numerous posts and videos and I'm pretty sure my recently installed and NPE 180-A2 may not be recirculating correctly through the Navicirc manifold.

I've had it about a month now and used the intelligent recirculation option (originally set by the plumber) for the first 3 weeks. When it didn't seem to change the wait time for hot water for my morning shower (approx same time every day give or take a few minutes), I decided to change it to the daily setting and set it to come on at least an hour before the shower time and afterwards.

That didn't seem to change anything either so I selected always active and then ran the bathroom sink where the Navicirc is installed and that takes a 90 seconds before hot water starts flowing.

With the research setting on always active, shouldn't the sink with the nabi circ at least get some hot water quicker than 90 seconds?

I've checked the manuals (there's not much about it in the user manual but the install manual has some info ) internal valve and it is set to external circulation as well as the menu items and the setting for external pump is set to "no".

Some previous videos also mention DIP switches above the menu screen, but my model does not have those as far as I can tell but there are four DIP switches to the right of the menu assembly

The plumbing looks the same as in the manual except I don't see the temperature sensor anywhere, but I'm assuming that is only used with the hot button option?

Just double checking to make sure I understand how it should work before I give the plumber a call. Anything else I chould check? I'm in Florida if that matters.


navicirc.jpg
Screenshot 2023-06-04 152219.jpg
 

Fitter30

Well-Known Member
Messages
4,509
Reaction score
846
Points
113
Location
Peace valley missouri
Have you looked at.pages 29 to 36? Is the internal external valve set correctly.
 

coolgreany

New Member
Messages
9
Reaction score
0
Points
1
Location
Florida
Have you looked at.pages 29 to 36? Is the internal external valve set correctly.
@Fitter30 , Thanks for your reply.

Yes, I have looked at pages 29 to 36 in the manual. As far as I can see, the valve is set correctly to "EXTERNAL." when using the Navicirc manifold/valve.

As I mentioned earlier, "I've checked the manuals (there's not much about it in the user manual but the install manual has some info ) internal valve and it is set to external circulation as well as the menu items and the setting for external pump is set to "NO".

Page 35 of the manual states to set the valve to External when using the Navicirc valve (which is what it has been set at all along).

Are you saying the valve should be set to internal or the menu should be set to YES for the external pump?
 
Last edited:

Fitter30

Well-Known Member
Messages
4,509
Reaction score
846
Points
113
Location
Peace valley missouri
@Fitter30 , Thanks for your reply.

Yes, I have looked at pages 29 to 36 in the manual. As far as I can see, the valve is set correctly to "EXTERNAL." when using the Navicirc manifold/valve.

As I mentioned earlier, "I've checked the manuals (there's not much about it in the user manual but the install manual has some info ) internal valve and it is set to external circulation as well as the menu items and the setting for external pump is set to "NO".

Page 35 of the manual states to set the valve to External when using the Navicirc valve (which is what it has been set at all along).

Are you saying the valve should be set to internal or the menu should be set to YES for the external pump?
No just making sure we're on the same page. Check flow rate and water temps under basic information.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks