Kinetico Float Adjustment

Users who are viewing this thread

Drewsonian

New Member
Messages
5
Reaction score
0
Points
1
Location
Central Ohio
Hi,

I recently moved my Kinetico Model 60 softener as a part of remodeling my basement. It was working well before the move. However, I think I may have inadvertently changed the float height setting because after moving the softener, we are now running out of soft water just before each regeneration cycle starts. I've found a few manuals online that describe letter based settings like D/G/H/J, but my brine well does not have "tabs" like most of these describe and no letters at all. There is a grid in the bottom of the tank. There are slots on the sides of the brine well, but the only adjustment that I can find are lines on the float cup assembly rod. Is there a measurement or one of these lines that I should be making sure that the float cup is set to? Also, do these lines correspond with the salt dosage? I've also considered changing out the disc (currently have a #5), but I want to get the float setting right to see if that changes anything.

Thanks for your help!
Drew
 

GoWater

New Member
Messages
9
Reaction score
0
Points
1
Location
California
The lines do correspond with the salt dosage.
Attach a picture of the float assembly and I can help you.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks