My Pump Saga Continued

Discussion in 'Pumps and Tanks Well Forum & Blog' started by gmrules, Feb 11, 2009.

  1. gmrules

    gmrules New Member

    Messages:
    94
    Location:
    Raleigh NC
    not sure if any recalls or cares :))

    I had thread where my starter cap went and value man and everyone helpedme as usual.

    I installed CSV still having to reset the control box, was trying to avoid the dreaded pump replacement

    Finally I did it yesterday and to my surprise when I pulled the pump I foound that when I Installed 4 short years ago I must have scraped the wire on the casing see attached Pic,

    So do you guys think this was the root cause or the constant cycling or both?


    Thanks again all


    here is thread in case anyone wants to refresh

    Attached Files:

  2. speedbump

    speedbump Previous member

    Messages:
    4,540
    Location:
    Riverview, Fl.
    It certainly could have been the cause of the pump not working correctly.

    bob...
Similar Threads: Pump Saga
Forum Title Date
Pumps and Tanks Well Forum & Blog PIpe used for hooking up pressure tank to well pump? Yesterday at 6:26 AM
Pumps and Tanks Well Forum & Blog well pump bladder tank used as expansion tank Saturday at 8:56 PM
Pumps and Tanks Well Forum & Blog Booster pump Is dying - need replacement help Dec 12, 2014
Pumps and Tanks Well Forum & Blog Setting pump with poly pipe at 400' Dec 9, 2014
Pumps and Tanks Well Forum & Blog Looking for comments on well/pump Dec 8, 2014

Share This Page