Floating black rubber/plastic? pieces in my Brine tank...help!

Discussion in 'Water Softener Forum, Questions and Answers' started by aaronbart, Apr 15, 2014.

  1. aaronbart

    aaronbart New Member

    Apr 15, 2014
    Fleck 7000SXT Meter Water Softener - 40,000 Grain Capacity
    [Brine Tank Size:18x33 Round Brine Tank 10]
    [Res-Care Feeder:NO Res-Care Feeder]
    [Resin Media Option:Hi-Capacity Resin - 8% Crosslink]
    [Turbulator Option:NO Turbulator 10x44 Tank]
    [Plumbing Connection:BYPASS, Noryl 1-1/4" Male NPT]

    I purchased my Fleck in December and installed myself, no troubles and everything has been working great. Today I go to check the brine level and see lots of bits of black floating in the tank. From what I can tell they look like a soft rubber/plastic. Has anyone ever experienced this? My worst fear is that a gear or gasket has sheared and the remains are sitting in my brine tank. I don't want to go tearing into a brand new unit if I don't have to. So far I don't see any external signs of damage. Thanks for help in advance!

  2. mialynette2003

    mialynette2003 Member

    Nov 24, 2010
    Owner of SWS Systems WWW.SWSSYSTEM.COM
    Ocala, Florida
    Anyway to post a pic of the debris? No way of knowing what it is without seeing it.
  3. Sponsor

    Sponsor Paid Advertisement

  4. SHR

    SHR Member

    Mar 9, 2014
    Journeyman Plumber
    When you installed it yourself, did you use flex lines?
Similar Threads: Floating black
Forum Title Date
Water Softener Forum, Questions and Answers Black Water After Softener Install Jul 29, 2015
Water Softener Forum, Questions and Answers Black Water Mystery Jun 13, 2013
Water Softener Forum, Questions and Answers Black water after regeneration.... Oct 13, 2011
Water Softener Forum, Questions and Answers Black sediment coming from Water Softener Feb 19, 2010

Share This Page