wellmate problems?????

Discussion in 'Pumps and Tanks Well Forum & Blog' started by tonytartufo, Apr 11, 2009.

  1. tonytartufo

    tonytartufo New Member

    Messages:
    8
    Hey guys. I'm new here and I really need help!

    I recently purchased a home that uses well water. In my basement I have 2 big grey Wellmate expansion tanks??????? with a clear plastic tube running vertical between the two tanks that is usualy filled with water. Both the tank and the clear tube are connected through a series of pvc pipes.

    To the right of these tanks I have a pump and to the right of that I have a Welltrol tank with a pressure gauge next to it. Pressure is usually at around 60.

    HERE ARE MY QUESTIONS....................

    1st. Why do I have all of these tanks? Do they do the same thing? What does what? Do I need all of this?

    2nd. Today I noticed the pump running more than usual and the water in the clear tube is just about gone. I had the hose running for about an hour outside because of my wet tile saw. Is this normal that the tube is almost empty and whenever the pump kicks on it's not filling? How does this system work?

    If you guys need me to post pics let me know.

    Thanks in advance.................

    Tony
  2. Gary Slusser

    Gary Slusser That's all folks!

    Yes post pictures. And describe the stuff as if we are blind; is specific detail from the well to the last piece.

    Did you run out of water?
Similar Threads: wellmate problems
Forum Title Date
Pumps and Tanks Well Forum & Blog Problems with Wellmate SP-series pressure tanks? Jan 3, 2013
Pumps and Tanks Well Forum & Blog Would you take a Well-x-trol tank over a Wellmate even in a tropical environment Oct 28, 2014
Pumps and Tanks Well Forum & Blog Question about WellMate pressure tank Jul 28, 2014
Pumps and Tanks Well Forum & Blog wellmate water tank Feb 12, 2013
Pumps and Tanks Well Forum & Blog Wellmate pressure tank leaking May 31, 2012

Share This Page