Well problem! Help please:

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Bob G, May 30, 2006.

  1. Bob G

    Bob G New Member

    Messages:
    1
    Just bought a lot with a 3 year old well! My problem is lights flicker when well pump cuts on and off! The pump will cycle off and on many times (6 to 8) before reaching the cutoff pressure of 50 lbs. The pressure switch and gage is located in the well casting and connected to a pitless adapter with a 1/2" dia. 6' long rubber hose! You can pull the switch and gage out of the well! The bladder tank is underground (Now exposed) 32' away! I dug up and adjusted the tank to 28 lbs of air pressure (when I checked it it only had 8 lbs). The line then runs 100' to the house. The contacts on the old pressure switch looked burnt, so I replace with New Switch (30/50)! Pump still cycles on and off many times before reaching cutoff pressure. Would putting the switch in the casting and connecting to the pitless adapter w/ 6' hose cause this problem or is the tank and switch to far apart? Any advice would be appreciated!
  2. valveman

    valveman Moderator Staff Member

    Messages:
    4,485
    Location:
    Lubbock, Texas
    Valveman

    If the tank was just outside the well you might get away with it. 32' is a long way for the tank to be from the switch. Still could be problems with the tank itself. Is it a fiberglass tank or steel? Is the tank vertical or horizontal? Fiberglass tank installed horizontal is no good. If the tank is good, you might make it work by using a pressure snubber (like Ray Roberts snubber) and water hammer arrestor tank (size of baseball) before the pressure switch.
  3. Bob NH

    Bob NH In the Trades

    Messages:
    3,317
    Location:
    New Hampshire
    I would do two things:
    1. Move the pressure switch to near the tank, with a pressure gauge.
    2. Check for proper air in the tank and set it to 2 psi less than the ON pressure of the switch.

    If the pressure switch is at the tank you don't need a snubber.
Similar Threads: problem Help
Forum Title Date
Pumps and Tanks Well Forum & Blog Help diagnosing well pump problem Jun 7, 2014
Pumps and Tanks Well Forum & Blog Well problems. Please help Feb 5, 2014
Pumps and Tanks Well Forum & Blog Problem with starite 1hp pump HELP Jan 4, 2014
Pumps and Tanks Well Forum & Blog PLEASE HELP.....New Conv. Jet Pump Problems!!!! Jul 5, 2013
Pumps and Tanks Well Forum & Blog Problem After WX1-250 Install, Need Troubleshooting Help Nov 8, 2012

Share This Page