Water softener making clicking sound.

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by martinG1, Dec 18, 2008.

  1. martinG1

    martinG1 New Member

    Dec 18, 2008
    Hello Everyone,

    I'm new to the forum. I have a Hague model 94 mm that's making a clicking sound. It sounds as if the relay (or is it a piston) clicks on/off in a cyclic manner when it's plugged in. Maybe the piston is stuck? The display works so I know I'm getting power to it but maybe not enough current? The water softener never regenerates so I'm getting hard water. I've surfed the web to no avail. Please advise and thanks in advance!
  2. Gary Slusser

    Gary Slusser That's all folks!

    Aug 31, 2004
    Wherever I park the motorhome.
    It sounds as if something is stuck and the motor gearing is skipping or a clutch lets go. I don't know much if anything about a Hague control valve but it might be a highly modified timer on a Fleck 5600.

    Go to Hague's web site and see if you can download a manual if you don't have one or call their dealer in your area for service.

    I suggest that next time you don't buy a proprietary control valve or softener so you can fix it yourself with parts you can get from many other locations.
  3. Sponsor

    Sponsor Paid Advertisement

Similar Threads: Water softener
Forum Title Date
Plumbing Forum, Professional & DIY Advice water softener discharge line help Wednesday at 12:58 PM
Plumbing Forum, Professional & DIY Advice Fire sprinkler alarm problem since water softener install Oct 8, 2016
Plumbing Forum, Professional & DIY Advice Musty smell from new water softener Aug 19, 2016
Plumbing Forum, Professional & DIY Advice Water Softener Drain May 29, 2016
Plumbing Forum, Professional & DIY Advice Rough in Water Softener May 20, 2016

Share This Page