Water softener making clicking sound.

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by martinG1, Dec 18, 2008.

  1. martinG1

    martinG1 New Member

    Messages:
    1
    Location:
    Texas
    Hello Everyone,

    I'm new to the forum. I have a Hague model 94 mm that's making a clicking sound. It sounds as if the relay (or is it a piston) clicks on/off in a cyclic manner when it's plugged in. Maybe the piston is stuck? The display works so I know I'm getting power to it but maybe not enough current? The water softener never regenerates so I'm getting hard water. I've surfed the web to no avail. Please advise and thanks in advance!
  2. Gary Slusser

    Gary Slusser That's all folks!

    It sounds as if something is stuck and the motor gearing is skipping or a clutch lets go. I don't know much if anything about a Hague control valve but it might be a highly modified timer on a Fleck 5600.

    Go to Hague's web site and see if you can download a manual if you don't have one or call their dealer in your area for service.

    I suggest that next time you don't buy a proprietary control valve or softener so you can fix it yourself with parts you can get from many other locations.
Similar Threads: Water softener
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Water softener installation problem Jul 18, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Water Softener Drain Line Question Jul 11, 2014
Plumbing Forum, Professional & DIY Advice, Tips & new water softener - sizing - type - etc Jun 27, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Need Advice Please Water Softener/Condenstate Drain Backup Issue Feb 1, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Water Softener question Dec 31, 2013

Share This Page