Water a little dingy after regen

Discussion in 'Water Softener Forum, problems, installation and r' started by yeto, Apr 4, 2014.

  1. yeto

    yeto New Member

    Messages:
    26
    Location:
    SC
    I did a resin bed cleaning using SIO and my water was crystal clear and smelled and felt clean. After 500 gallons the system regened and now the water is slightly dingy with a slight smell. I am using the green bags of salt with the iron out additive. Would anyone know as to why I was not getting dingy water before the regen with the SIO resin bed cleaning and now I am getting dingy water after the regen? I did not use any water during the regen because my WaterBoss softener goes into bypass during regen and I didn't want any hard water to enter the house.

    Gary advised to just use SIO and not to use the green bags of salt and I am thinking this will be the best solution for me. After the resin bed cleaning with SIO my water was crystal clear.

    I think I read somewhere that SIO will reduce the life of the resin. Is this true?

    Thanks in advance for any help,
    yeto
    Last edited: Apr 4, 2014
  2. mialynette2003

    mialynette2003 Member

    Messages:
    736
    Location:
    Ocala, Florida
    If you have gone a number of months removing from the water and now are trying to clean the resin, it could be the system is not rinsing the resin completely of the iron you are trying to clean off the resin. Try a back to back regen.
  3. mialynette2003

    mialynette2003 Member

    Messages:
    736
    Location:
    Ocala, Florida
    For some reason, it won't let me edit my post so here is the edited version.

    If you have gone a number of months removing iron from the water without using a resin cleaner (iron out) and now are trying to clean the resin, it could be the system is not rinsing all the iron off the resin. Try a back to back regen or it may take several regens to properly rinse.
  4. yeto

    yeto New Member

    Messages:
    26
    Location:
    SC
    I will try the multiple regens.

    Thank you for your help,
    yeto
Similar Threads: Water little
Forum Title Date
Water Softener Forum, problems, installation and r Little iron still in water after brand new Softener installed Aug 16, 2012
Water Softener Forum, problems, installation and r Another water softener sizing question Yesterday at 6:53 AM
Water Softener Forum, problems, installation and r Water not reaching salt in brine tank; no soft water. Sep 8, 2014
Water Softener Forum, problems, installation and r Water Softener Settings & Documentation Sep 8, 2014
Water Softener Forum, problems, installation and r Another Water Softener Sizing Question - Part Time Vacation Rental Sep 4, 2014

Share This Page