sand point windmill pump low flow no flow

Discussion in 'Pumps and Tanks Well Forum & Blog' started by rzinke, Nov 2, 2013.

  1. rzinke

    rzinke New Member

    Joined:
    Nov 2, 2013
    Location:
    Il
    I recently purchased a house that has a windmill with what I've been told is a sand point well under it. When I turn on the motor for the pump jack to pump water I had some water flowing but now only a few pumps will give water then nothing. I noticed if I tap the pipe lightly with a hammer it will pull up some water. There is about a 2 1/2 ft pit and a small pipe in the center that is attached to the pump head at the surface. There is about 1 1/2 feet of water at the bottom of the pit. I stuck a pole in the pit a it feels like it is about 8 ft deep total. I think there is a joint just below the water line when I used the pipe to explore the depth. Does it sound like the point is plugged and need to abandon fixing it or does anyone have any ideas about how to approach this. I talked to local plumbers and the offered to pull the old one.

    And help will be appreciated.
     
Similar Threads: sand point
Forum Title Date
Pumps and Tanks Well Forum & Blog Shallow Well Sand Point Losing Prime Overnight? May 8, 2016
Pumps and Tanks Well Forum & Blog Sand Point Well Low Yield Nov 12, 2015
Pumps and Tanks Well Forum & Blog DIY Shallow Well with 1-1/4" Sandpoint Installation Nov 10, 2015
Pumps and Tanks Well Forum & Blog SAND POINT SHALLOW WELL ?'s Nov 5, 2015
Pumps and Tanks Well Forum & Blog Shallow well (sand point?) not pumping any water Oct 16, 2015

Share This Page