Pump starts...... Won't stay running

Discussion in 'Pumps and Tanks Well Forum & Blog' started by XFIRE, Jan 14, 2013.

  1. XFIRE

    XFIRE New Member

    Messages:
    1
    Location:
    Florida
    My primary area is with filtration so pump troubleshooting is a bit out of the norm.

    Scenario:
    Pump (submerged) starts and runs for approx. 5 seconds before tripping the reset breaker.
    Have checked voltage, wiring, changed both capacitors.
    An associate suggested that the pump might have got sand blocked for not enough usage and that it needs to be pulled???? Another suggested to just replace the control panel entirely. The only part I haven't checked is the relay in the box.
    Any input from the pump experts is appreciated.
  2. valveman

    valveman Moderator Staff Member

    Messages:
    4,426
    Location:
    Lubbock, Texas
    The relay can make it trip the overload. I wouldn't pull the pump until I made sure the control box is all good. But the motor is probably locked up and that is what is tripping the overload.
Similar Threads: Pump starts
Forum Title Date
Pumps and Tanks Well Forum & Blog Pump Stops and Starts Jan 16, 2012
Pumps and Tanks Well Forum & Blog need help just replaced well tank and now air every time pump starts Sep 7, 2011
Pumps and Tanks Well Forum & Blog Pump Starts then stops Jan 20, 2011
Pumps and Tanks Well Forum & Blog Well Pump intermittently stops, buzzes, then starts working again Dec 13, 2010
Pumps and Tanks Well Forum & Blog pump stops then starts Aug 22, 2009

Share This Page