pump runs continuously

Discussion in 'Pumps and Tanks Well Forum & Blog' started by nanshtly, Jul 1, 2009.

  1. nanshtly

    nanshtly New Member

    Messages:
    2
    we have replaced the pressure switch and the water tank and pressure gauge.but still wont build up more than 35psi to cut off the pump.there are no leaks visible.pump is submersible.is it a weak pump or bad foot valve?
  2. Gary Slusser

    Gary Slusser That's all folks!

    Thanks for posting your PM here.

    It sounds as if you have a leak preventing the pump from building more pressure, but that isn't the only possible cause. It could be something blocking the inlet to the pump etc..

    Shut of the water to the house past the pressure tank. Shut off the power to the pump.

    Watch the pressure gauge for like 5 minutes and see if the pressure decreases. If it does you have a water leak between the pressure tank and the pump. Probably in the drop pipe in the well.

    That only works if you don't have any extra check valves like one before the tank.

    If the pressure holds, you need to check the electrical tests of the pump and power cable. Here's a link to learn how to do that and if you can't or don't want to then call a pump guy, driller or only a plumber that is willing and capable of pulling the pump and replacing it.
    http://www.franklin-electric.com/business/WaterSystems/service/AIM/page-43.aspx
    Last edited: Jul 1, 2009
  3. Thatguy

    Thatguy Homeowner

    Messages:
    1,459
    Location:
    MD
    Yes, check if your power input to the pump, voltage and current draw, is within spec's.
Similar Threads: pump runs
Forum Title Date
Pumps and Tanks Well Forum & Blog Help diagnosing a well pump that runs every 10 minutes Apr 20, 2014
Pumps and Tanks Well Forum & Blog Deep well jet pump runs but no output Jan 8, 2014
Pumps and Tanks Well Forum & Blog Supply line froze, after thawing water runs back into well when pump stops... Jan 4, 2014
Pumps and Tanks Well Forum & Blog Pump Runs Non Stop trying to reach cut off pressure setting May 6, 2013
Pumps and Tanks Well Forum & Blog Another pump-runs-continuously-but-tank-not-filling thread Mar 8, 2013

Share This Page