Problem with SJE Rhombus Vertical Master!

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by davidrosshodges, Dec 14, 2009.

  1. davidrosshodges

    davidrosshodges New Member

    Messages:
    1
    Location:
    New Jersey, USA
    I came home a few days ago to find my sump pump running continuously. I have a battery backup pump which kicked in so fortunately no flooding.

    I have a regular sump pump, connected as a piggy back onto an SJE VerticalMaster II. I figured the VerticalMaster was broken, so bought a new one at the weekend, changed it, and every thing worked fine.

    Two days later, the same thing has happened again. So I've replaced the new float switch, with the old one, and it all works again. I'm sure in a few days, I'll be switching them over again!

    It seems like the float switch is resetting itself after a while, and then gets stuck. I tested the one I took out, with a lamp, and it is on the whole time, as i move the float up and down.

    Can anyone help me explain why this might be happening? We have had some cold weather the last few days, that's the only thing that has changed.
  2. Joy Stone

    Joy Stone Support

    Messages:
    1
    Location:
    Minnesota
    I am a representative of SJE-Rhombus, the manufacturer of the SJE VerticalMaster pump switch. I am sorry to learn of the issues you have experienced with the products you purchased. We would like to have the defective switches returned to our facility so that they can be evaluated and the root cause of failure determined.

    Please contact me at 888-DIAL-SJE ext. 3395 or by email at Joy.Stone@sjerhombus.com to arrange return of the product and determine what form of replacement product would work best in your application.

    Any information you can share about the make and model of your sump pump will help us determine how to assist you most effectively.

    Please visit our website at www.sjerhombus.com for additional company and product information.
  3. edlay2003

    edlay2003 New Member

    Messages:
    1
    Location:
    factoryville pa
    i have the same issue with my pump i need to find help quick i have to plug in my pump every 2 hours
Similar Threads: Problem Rhombus
Forum Title Date
Plumbing Forum, Professional & DIY Advice Weil McLain Eco 155 gas boiler constantly cycling problem Nov 16, 2014
Plumbing Forum, Professional & DIY Advice Rinnai R75LSi - Hot water problems for over a year! Nov 11, 2014
Plumbing Forum, Professional & DIY Advice Deep sink garbage disposal drain problems Nov 5, 2014
Plumbing Forum, Professional & DIY Advice Pipe expansion problem Nov 3, 2014
Plumbing Forum, Professional & DIY Advice Intermittent T-K2 problems Weird Nov 2, 2014

Share This Page