No prime, Myers Pump

Discussion in 'Pumps and Tanks Well Forum & Blog' started by tyancey66, Jul 20, 2011.

  1. tyancey66

    tyancey66 New Member

    Messages:
    1
    Location:
    Catoosa Oklahoma
    I recently purchased a house with a well, it has a myers pump, I removed the pressure guage on and filled the pump with water, put the gauge back on loosely and turned the pump on, did nothing, the water in the pump went no where, ran for a minute or two with no results. Any ideas?
  2. masterpumpman

    masterpumpman New Member

    Messages:
    729
    Location:
    Virginia Beach, VA
    It usually takes a while for the air to purge from the pump. Keep the pump full of water and let it run for about 5 minute and it should prime. Be sure that when priming through the guage hole that the pump is full of water!

    If it's an old system with an air volumn control the Air Volume control on the tank could be bad. If it has an AVC, plug the small line to the pump. If it primes then the AVC is bad.
Similar Threads: prime Myers
Forum Title Date
Pumps and Tanks Well Forum & Blog Please help. Losing pressure. Not prime. Jun 29, 2014
Pumps and Tanks Well Forum & Blog Stumped! Need to prime my pump. Jun 16, 2014
Pumps and Tanks Well Forum & Blog Irrigation pump loses prime overnight Aug 26, 2013
Pumps and Tanks Well Forum & Blog New Shallow Well Can't Get Primed Jun 15, 2013
Pumps and Tanks Well Forum & Blog New Shallow Well Jet Pump and Tank Won't Prime May 22, 2013

Share This Page