New Pump a year old still issue with dirt in water

Discussion in 'Pumps and Tanks Well Forum & Blog' started by watty770, Mar 3, 2011.

  1. watty770

    watty770 New Member

    Messages:
    2
    Location:
    Currituck, NC
    I have a well pump model Gould JR57 Jet Pump with a Flotec 15 gal tank. It works great except that I have to clean the cold water screen on the washer every week or so. I cannot say that our water is dirty though there is a cumulative effect in the shower floor that is very slight each week when we clean the floor (you can tell it was a little reddish). I live near the Outer Banks in NE NC and this is our first well. The new pump and tank are now over a year old. Is there a filter or something that can be done to fix what is a minor irritation? Thanks. Watty
  2. WellWaterProducts

    WellWaterProducts In the trades

    Messages:
    126
    Location:
    Northwood NH
    It sounds like a combination of iron, hardness and simple sediment. You could start by installing a simple cartridge filter after the pump/tank combo.
  3. watty770

    watty770 New Member

    Messages:
    2
    Location:
    Currituck, NC
    thanks for the suggestion!
Similar Threads: Pump still
Forum Title Date
Pumps and Tanks Well Forum & Blog water still dirty a week after new pump replacement Aug 30, 2012
Pumps and Tanks Well Forum & Blog Mouse shorted out the wire to my well switch and now I still have no pump after fix May 8, 2012
Pumps and Tanks Well Forum & Blog pump still runs but pressure stops at 40psi. May 7, 2011
Pumps and Tanks Well Forum & Blog Fixed Well Pump - Still Broken May 4, 2010
Pumps and Tanks Well Forum & Blog Pump Still Kicking Off Feb 24, 2009

Share This Page