Low pump pressure

Discussion in 'Pumps and Tanks Well Forum & Blog' started by stolog, Sep 7, 2013.

  1. stolog

    stolog New Member

    Sep 7, 2013
    Looking for some advice before I pull the pump out of the well to make sure I've tried everything else first.

    I've got a 100' well with a 3/4hp submersible 3 wire pump.
    I'm only getting about 40 psi max out of the pump.
    The switch was set at 50/60.
    I have a cycle stop valve installed but the entire setup is in a well pit so I can check the pressure before the valve.
    There is a check valve installed between the pump and the cycle stop and I'm taking readings between the pump and check valve.

    The pump is drawing about 9 amps per leg and the pump winding resistance is within spec.

    Running the pump maintains around 25-30psi and I have no problem pumping 20 or 30 gallons so it's not running dry.
    When the pump turns off the pressure on the pump side drops to 0.

    At this point I'm thinking the impeller on the pump is worn out or there is a hole/split in the polyethylene pipe?
    I know I replaced the pump several years ago but did not replace the polyethylene pipe.

    Any thoughts or suggestions other than pull the pump and see what comes out of the hole?

    Right now I have adjusted the pressure switch and tank down to run at 30-40 and turn the pump off when not in use till I figure out what happened.

    Last edited: Sep 7, 2013
  2. wondering

    wondering Member

    Dec 10, 2006
    Mine did the same thing and it was a split in the pipe right above the pump.
  3. Sponsor

    Sponsor Paid Advertisement

  4. craigpump

    craigpump Well-Known Member

    Apr 12, 2012
    Self employed water system tech
    Corroded fitting at the pump, split in the drop pipe or worn out pump with a bad check valve
  5. valveman

    valveman Moderator Staff Member

    Mar 15, 2006
    Pump Controls Technician
    Lubbock, Texas
    That is my guess as well.
Similar Threads: pump pressure
Forum Title Date
Pumps and Tanks Well Forum & Blog Help! Submersible well pump runs but won't build pressure over 30 psi! Nov 13, 2015
Pumps and Tanks Well Forum & Blog Well pump not shutting off or getting up to cut off pressure Oct 18, 2015
Pumps and Tanks Well Forum & Blog Pressure switch cycles on/off very rapid on booster pump Oct 14, 2015
Pumps and Tanks Well Forum & Blog Pressure drops when water pump shuts off Sep 7, 2015
Pumps and Tanks Well Forum & Blog New pump, new pressure tank throwing breaker Sep 6, 2015

Share This Page