Kinetico Water Softner 10 years old. UK compact under sink model

Discussion in 'Water Softener Forum, problems, installation and r' started by JaysJimlad, Dec 22, 2011.

  1. JaysJimlad

    JaysJimlad New Member

    Messages:
    2
    Location:
    Cotswolds UK
    Plan view of Softner email.jpg Brine tube & Float system email.jpg
    I have a Kinetico softener, which I had new 10 years ago. Like everyone on this forum I can't locate any info on troubleshooting problems. Also I can't relate my model to any US/Canadian models - I can't find any model number on the system. Mine is twin cylinder, see picture and the cylinders sit in the brine, all enclosed in a single tank. I use 2 block salt refills, each block is about 8.8 lb in weight. They stand on an open fret to ensure only the bottom edge of the blocks are in the water/brine
    I have a problem whereby the system regenerates correctly on one cylinder, i.e. ‘Brine – Rinse’ & ‘backwash’, which finishes by providing about 3/8th inch depth of water to interface with the bottom edge of the block salt. However, when the other cylinder is in regeneration, ‘Brine – Rinse’ is OK but at the end of backwash the water can be heard to be continually running, I think to drain and the 3/8th inch depth of water to interface with the bottom edge of the block salt is not supplied.

    So it is working one side but not the other!!

    My assumption is that I will need to get into the mechanism on top of the main cylinder and investigate what is malfunctioning??

    Has anyone got info on which ring of bolts I open first, the inner or outer first or all of them - is there a set order of undoing has anyone ant pictures or info please?

    Jaysjimlad

    Attached Files:

    Last edited: Dec 22, 2011
  2. mialynette2003

    mialynette2003 Member

    Messages:
    742
    Location:
    Ocala, Florida
    I have a parts diagram that my help. Send me an e-mail at affordablewtr@aol.com and I'll send you the break down.
  3. JaysJimlad

    JaysJimlad New Member

    Messages:
    2
    Location:
    Cotswolds UK
    Hi mialynette2003,

    Thank you for your response. Email is on it's way.

    I hope it will show me the detail of what the two diameters of bolts locate to, so I can start the disassembly??:confused:

    I don't want to end up breaking any seals that will require me to get replacements, that assumes I as a consumer/user can buy Kinetico spares.
    If anyone knows how I could obtain patrs I would appreciate your advice.

    I hope I will start the disassembly tomorrow - hopefully :) or :(

    Jays Jimlad :eek:
  4. Gary Slusser

    Gary Slusser That's all folks!

    On Youtube there are a large number of how to videos of guys working on Kinetico softeners.

    I don't know that you can get an old unit apart without damaging or needing to replace gaskets. And if you have a softener from the UK, the parts may not be the same as their newer parts.

    You may want to talk to:
    http://www.harveywatersofteners.co.uk/
  5. chevy427

    chevy427 Banned

    Messages:
    174
    Location:
    USA
    That unit corresponds to the US version 2020 (with 6" tanks). There are a couple a versions of the 2020. Disassembling the valve is quite easy with just a few things to keep in mind. Never use any petroleum products for lubrication or sealing. Let me know if you get the diagrams.

    Running to the drains may be caused by a few problems including quad-rings o-rings that have suffered from chlorinated water, quad-rings may be rolled, pinched, dirty or cracked, lose in incoming water pressure, foreign matter preventing a piston from shutting, balance piston not seating properly, scored control disc, etc. Most of these can be remedied easily. A scored disc, which is not common, would require replacement.

    Do you have a pre-filter to eliminate chlorine and/or catch sediment?

    Not sure how "Harvey" can help as they are competitors and not complimentary to Kinetico equipment.
  6. Gary Slusser

    Gary Slusser That's all folks!

  7. Ozzy

    Ozzy New Member

    Messages:
    1
    Location:
    Uk
    Hi jaysjimlad, did you have any luck with your softener? If not we can help you if you would like to get in touch. www.s-s-s.biz
Similar Threads: Kinetico Water
Forum Title Date
Water Softener Forum, problems, installation and r Darn water is too salty Kinetico Signature Series Nov 10, 2014
Water Softener Forum, problems, installation and r Kinetico water softener and salty tasting water Aug 10, 2014
Water Softener Forum, problems, installation and r Kinetico Waterplant works on 1 side only Aug 4, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Salt taste in house water May 20, 2014
Water Softener Forum, problems, installation and r Kinetico water softener problems Jul 27, 2013

Share This Page