Kinetico Model 60 won't draw

Discussion in 'Water Softener Forum, problems, installation and r' started by GaryG, Sep 3, 2012.

  1. GaryG

    GaryG New Member

    Messages:
    3
    Location:
    Washington
    Hi,

    I have a Kinetico Model 60, which stopped drawing brine. During the brine cycle, water continues to flow to the brine tank (no suction). It won't drwa on either the normal timer or the manual regeneration.

    Here is what I have done already:
    1. disconnected brine line (confirmed there is no suction, but rather water flow from the head)
    2. blew out drain line (it was not plugged)
    3. Took Head apart
    .... confirmed gears and turbine spin freely
    .... blew air through the venturi and all the openings
    .... verified all the valves move freely
    .... confirmed check valves are in place.

    Any ideas on what to try next?
  2. chevy427

    chevy427 Banned

    Messages:
    174
    Location:
    USA
    In the base level, are there balls or pegs? The brine draw occurs about two minutes after regeneration initiates.

    Water pushes toward the brine tank during all other stages.

    It could be the control disc is worn. Have you checked the ridges?
  3. GaryG

    GaryG New Member

    Messages:
    3
    Location:
    Washington
    The base level has pegs. The unit is almost new. The control disc doesn't look worn.

    Gary
  4. mialynette2003

    mialynette2003 Member

    Messages:
    747
    Location:
    Ocala, Florida
    Check the drain flow controller for the debris. Hold the venturi up to the light to make sure no blockage is present.
  5. GaryG

    GaryG New Member

    Messages:
    3
    Location:
    Washington
    Hi,

    Checked the drain flow controller and it was clear. Also checked the venturi, which was also clear.

    Any other ideas?
    Thanks
    Gary
Similar Threads: Kinetico Model
Forum Title Date
Water Softener Forum, problems, installation and r KINETICO Model 60 PAWL LAYOUT Sep 15, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Toothed Disk Operation Sep 12, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 problem with manually turing disc to regen Sep 11, 2014
Water Softener Forum, problems, installation and r SEQUENCE OF OPERATION for KINETICO MODEL 60? Sep 10, 2014
Water Softener Forum, problems, installation and r Need a manual for a 20 year old model 60 KINETICO Sep 9, 2014

Share This Page