Help!!! Pump keeps running and won't stop!!!

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Kevin Bradford, May 29, 2012.

  1. Kevin Bradford

    Kevin Bradford New Member

    Messages:
    1
    Location:
    Tennessee
    I am a newbie here and do not have any experience with this sort of thing so please be gentle.

    I have a WaterAce pump, what appears to be a jet pump. Not really sure because I am not very familiar with these things and I can't get the model number. It pulls water from a spring box up to the home. I have noticed that the pump runs for a few seconds and shuts off for about 30-40 seconds then comes back on and runs for another second or two. I have checked to see if anything is leaking or running in the home and there is not. This morning I went under the house to check and found that the pump itself is leaking from somewhere at the top of the tank between what I can tell is the pump and motor. Is there anyway that this can be repaired or do I need to replace the pump? If it can be repaired, what exactly could the problem be? Any help would be appreciated, thanks.
  2. valveman

    valveman Moderator Staff Member

    Messages:
    4,369
    Location:
    Lubbock, Texas
    Leaking between the pump and motor is the seal. It can be repaired with a new seal, but you have to take the impeller off to get to it.
Similar Threads: Help Pump
Forum Title Date
Pumps and Tanks Well Forum & Blog Need exterior sump pump help Jun 23, 2014
Pumps and Tanks Well Forum & Blog Can only pull out 6 inches of Drop Pipe and Pump, Please Help!!! Jun 16, 2014
Pumps and Tanks Well Forum & Blog Help checking my installation plan for submersible pump (and a question) Jun 7, 2014
Pumps and Tanks Well Forum & Blog Help diagnosing well pump problem Jun 7, 2014
Pumps and Tanks Well Forum & Blog newbie needs help pumping uphill to house May 30, 2014

Share This Page