Help!!! Pump keeps running and won't stop!!!

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Kevin Bradford, May 29, 2012.

  1. Kevin Bradford

    Kevin Bradford New Member

    May 29, 2012
    I am a newbie here and do not have any experience with this sort of thing so please be gentle.

    I have a WaterAce pump, what appears to be a jet pump. Not really sure because I am not very familiar with these things and I can't get the model number. It pulls water from a spring box up to the home. I have noticed that the pump runs for a few seconds and shuts off for about 30-40 seconds then comes back on and runs for another second or two. I have checked to see if anything is leaking or running in the home and there is not. This morning I went under the house to check and found that the pump itself is leaking from somewhere at the top of the tank between what I can tell is the pump and motor. Is there anyway that this can be repaired or do I need to replace the pump? If it can be repaired, what exactly could the problem be? Any help would be appreciated, thanks.
  2. valveman

    valveman Moderator Staff Member

    Mar 15, 2006
    Pump Controls Technician
    Lubbock, Texas
    Leaking between the pump and motor is the seal. It can be repaired with a new seal, but you have to take the impeller off to get to it.
  3. Sponsor

    Sponsor Paid Advertisement

Similar Threads: Help Pump
Forum Title Date
Pumps and Tanks Well Forum & Blog New well owner! Pump sizing and brand help... Wednesday at 1:37 PM
Pumps and Tanks Well Forum & Blog Help understaning what is wrong with jet pump setup Sep 25, 2015
Pumps and Tanks Well Forum & Blog Shallow well or deep well? Well pump help! Sep 18, 2015
Pumps and Tanks Well Forum & Blog need help choosing new well pump Aug 17, 2015
Pumps and Tanks Well Forum & Blog Problem with jet pump please help!!! Jun 28, 2015

Share This Page