Florida shallow well pump - Losing prime while running

Discussion in 'Pumps and Tanks Well Forum & Blog' started by surfdesign, Aug 17, 2007.

  1. surfdesign

    surfdesign New Member

    Messages:
    1
    I just replaced my shallow well pump with a 1hp Sta-Rite pump. There are no leaks in the plumbing (using a pvc check valve), however it will not hold a prime.

    Also, once it's primed and running, I can open the bib on the discharge end and get a great water flow, but when I close the bib and turn on the sprinkler system, I get a good burst of water (using the 2 gal bladder tank) then it takes a few seconds for the sprinkers to pop back up and run. The sprinklers run for about 5 minutes at full force then slowly for the next 2-10 minutes slow down and just barely drip water. I can then open the hose bib and get a good flow of water from the bib in about 30 seconds and the sprinklers run full force again while water is gushing out of the discharge bib. I can't for the life of me figure this out...

    Any help before I have to call someone out?

    Thanks
  2. leejosepho

    leejosepho DIY scratch-pad engineer

    Are you having to actually re-prime the pump to get it going again, or are you only stopping the flow and waiting for it to catch up?

    I am not a pump expert, but it sounds to me like your demand is occasionally greater than your supply.
  3. speedbump

    speedbump Previous member

    Messages:
    4,540
    Location:
    Riverview, Fl.
    I would get me a good check valve made of brass not plastic.

    If the sprinklers run for several minutes, that must be more than 2 gallons from your tank. So, is the well maybe just not giving the water you need. Tell us about the well. Size, depth to water etc.

    bob...
Similar Threads: Florida shallow
Forum Title Date
Pumps and Tanks Well Forum & Blog Driving Well in South Florida May 18, 2008
Pumps and Tanks Well Forum & Blog Replacing pump in shallow well Jun 9, 2014
Pumps and Tanks Well Forum & Blog New Versajet on old shallow well system problem Apr 26, 2014
Pumps and Tanks Well Forum & Blog Trying to fix/update an OLD shallow well, this should be interesting Apr 25, 2014
Pumps and Tanks Well Forum & Blog Shallow well jet pump question Apr 13, 2014

Share This Page