Flack 5600 question

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by Sprink669, Apr 5, 2008.

  1. Sprink669

    Sprink669 New Member

    Messages:
    1
    Fleck 5600 question

    I have a problem with my Fleck 5600, I had a cracked "injector body" and I replaced that along with new O-rings. I went to turn the water back on and now it wants to fill up the salt tank and keep filling up the tank even in the "in service" position? I have searched and found a post about having to replace the "piston rod assembly and the plastic spacers and O-rings"? Along with a new "brine valve piston assembly" I have checked the O-rings and they seem to be seated but I can't figure this one out? Thanks!

    J
    Last edited: Apr 5, 2008
  2. Gary Slusser

    Gary Slusser That's all folks!

    About the only way I know of to crack an injector body is to over tighten the two screws, or not have the piece of tube that goes on the one screw as a spacer. That's unless the brine valve cracked it somehow.

    Now you should inspect the orings on the brine valve, it may be allowing a leak to the brine tank during service. You may have one on wrong or damaged.

    You'd have to look at the flow diagram to see if the seals and piston could cause it; I'm unsure if they would.
Similar Threads: Flack 5600
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & What's the better water softener? Fleck5600SXT or Aqua System Smart choice. Sep 5, 2008
Plumbing Forum, Professional & DIY Advice, Tips & Fleck 5600 or 5600SE Feb 19, 2008
Plumbing Forum, Professional & DIY Advice, Tips & Fleck 5600 Nov 8, 2007
Plumbing Forum, Professional & DIY Advice, Tips & Fleck 5600 Valve Problem Aug 20, 2007
Plumbing Forum, Professional & DIY Advice, Tips & Fleck 5600SE water softener programming Jul 31, 2007

Share This Page