deep well pump won't reach shutoff pressure

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Lynnfish, Aug 12, 2010.

  1. Lynnfish

    Lynnfish New Member

    Messages:
    6
    1 hp Starite deep well, with packer ejector and foot valve. Filled pipe and pump thru pressure gage. Holds prime. Started with the pressure Regulator completely closed. Pressures to 40lbs. right away but will not reach shutoff pressure of 50lbs. Pressure drops to zero immideiately when power is cut. Please let me know if I can provide any more info. Thanks so much for your time and advice!
    Lynn
  2. masterpumpman

    masterpumpman New Member

    Messages:
    729
    Location:
    Virginia Beach, VA
    It sounds like the nozzle in the injector is partially plugged causing the low pressure. Not holding pressure usually means the packer leathers are leaking or a leak in the well casing.
  3. Lynnfish

    Lynnfish New Member

    Messages:
    6
    we had the pump rebuilt and they left out a gasket , we carefully cut a gasket and re-assembled the pump could there be an enternal leak in the pump . we have a shut off valve one foot from pressure control valve , so the system should pump up right away , one would think. we had the pipe out of the well. we installed a new foot valve , new leathers, new gasket and plunger internal to the ejector, inspected the venturi and there was no blockage. i am at a loss for words damn it
Similar Threads: deep pump
Forum Title Date
Pumps and Tanks Well Forum & Blog Wires pulled out of deep well pump, don't know where they go Yesterday at 11:20 AM
Pumps and Tanks Well Forum & Blog Hand pump for very deep well? Oct 15, 2014
Pumps and Tanks Well Forum & Blog Deep Well Pump Replacement Jun 19, 2014
Pumps and Tanks Well Forum & Blog Deep well pump (?) problem Apr 29, 2014
Pumps and Tanks Well Forum & Blog Deep well jet pump runs but no output Jan 8, 2014

Share This Page