Deep well jet pump problems

Discussion in 'Pumps and Tanks Well Forum & Blog. Water is life.' started by Goodiemobb, Mar 21, 2007.

  1. Goodiemobb

    Goodiemobb New Member

    Joined:
    Mar 20, 2007
    I recently installed a new 1 hp deep well jet pump, it was set at 30/50 psi. It took a while to get a prime but once it was primed the gauge(new) would not go over 30 - 35 which means the pump would not shut off. I have checked the pressure in the pressure tank with a tire gauge and it read 30 psi. which I was told it should be 28 - 32, So that shouldn't be the problem. Also, when I did shut the pump down, it did still maintain the pressure. Any ideas what the problem is? Thanks in advance.

    PS.
     
  2. sammyhydro11

    sammyhydro11 Previous member

    Joined:
    Dec 20, 2006
    Occupation:
    Well Drilling-Test Borings-Water Treatment-Well an
    Location:
    Massachusetts
    GoodieMobb,
    cool name. It sounds like the jet assembly in your well might be clogged. What size well do you have and where is the pump located in relation to it?

    SAM
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Deep pump
Forum Title Date
Pumps and Tanks Well Forum & Blog. Water is life. How to repair Goulds deep-well pump Saturday at 12:29 PM
Pumps and Tanks Well Forum & Blog. Water is life. Should I Winterize my deep well pump? Aug 20, 2016
Pumps and Tanks Well Forum & Blog. Water is life. Best deep pump Jul 27, 2016
Pumps and Tanks Well Forum & Blog. Water is life. Deep well pump with long run to storage tank May 13, 2016
Pumps and Tanks Well Forum & Blog. Water is life. Shallow well or deep well? Well pump help! Sep 18, 2015

Share This Page