Cyscle Stop Valve Clogged?

Discussion in 'Pumps and Tanks Well Forum & Blog' started by HayGrower, Aug 9, 2009.

  1. HayGrower

    HayGrower New Member

    Messages:
    1
    My 10 hp submersible irrigation pump keeps tripping the brand new breaker.
    I think the cycle stop valve may be clogged with sand debris but I have no idea where to start in cleaning it out. Do you have diagrams? suggestions?
    Thanks
  2. Gary Slusser

    Gary Slusser That's all folks!

    I'd check the electrical stuff, like the amps, ohms, shorts of the pump and cable first before I'd think the CSV was blocked but I don't think that would trip the breaker anyway.

    Why did you need a new breaker?
  3. valveman

    valveman Moderator Staff Member

    Messages:
    4,428
    Location:
    Lubbock, Texas
    It would take a lot of sand to stop up a CSV. If you have that much sand, then sand is probably your problem. 10 HP single phase sub pump? What size and color is the CSV? Why the new breaker, and has it ever started on the new breaker?
Similar Threads: Cyscle Stop
Forum Title Date
Pumps and Tanks Well Forum & Blog CycleStopValve installed, had an issue... Jul 14, 2014
Pumps and Tanks Well Forum & Blog Noises after installing Cycle Stop Valve Jun 2, 2014
Pumps and Tanks Well Forum & Blog Supply line froze, after thawing water runs back into well when pump stops... Jan 4, 2014
Pumps and Tanks Well Forum & Blog Water Stops then restarts Jan 1, 2014
Pumps and Tanks Well Forum & Blog Cycle stop Valve help Dec 8, 2013

Share This Page