control box humming and no water

Discussion in 'Pumps and Tanks Well Forum & Blog' started by snowman10200, Nov 14, 2013.

  1. snowman10200

    snowman10200 New Member

    Nov 14, 2013
    Victoria, TX
    I have a Red Jacket Control Box that is humming and the 3/4 hp pump is not pumping water on the submersible pump. no pressure on system so I assume the pump is not running,
    What are some things I can check to get water back to the house
  2. LLigetfa

    LLigetfa DIYer, not in the trades

    Feb 6, 2011
    Information Technology
    NW Ontario, Canada
    You could check voltage, current, and ohms resistance to diagnose the pump. You could check the relay and cap or caps in the control box.
  3. Sponsor

    Sponsor Paid Advertisement

  4. valveman

    valveman Moderator Staff Member

    Mar 15, 2006
    Pump Controls Technician
    Lubbock, Texas
    I would check to make sure I had 240 volts coming from the pressure switch. If that is correct I would just try a new control box. If you have the correct voltage and it still clicks and buzzes with a new control box, you have probably already cycled that motor to death.
  5. DonL

    DonL Jack of all trades Master of one

    Mar 30, 2011
    Rocket Scientist
    Houston, TX
    You should take a look in the control box to see what is humming.

    The start cap could be bad and may cause the relay to chatter or hum.

    It is not good for the motor.

    Good Luck.
    Last edited: Nov 15, 2013
Similar Threads: control humming
Forum Title Date
Pumps and Tanks Well Forum & Blog Well pump control box humming Sep 11, 2015
Pumps and Tanks Well Forum & Blog Humming Control Box Nov 1, 2005
Pumps and Tanks Well Forum & Blog Frost free control fluid for outdoor wells Sep 28, 2015
Pumps and Tanks Well Forum & Blog How to best control well pump and cistern Sep 23, 2015
Pumps and Tanks Well Forum & Blog Unorthodox Pump Control? Sep 2, 2015

Share This Page