brine softwater problem

Discussion in 'Water Softener Forum, problems, installation and r' started by softwateruser, Apr 18, 2009.

  1. softwateruser

    softwateruser New Member

    Joined:
    Apr 18, 2009
    I have a fleck model 5600 or 5600 econominder water softener that is not producing soft water. Is there a formula to clean the system? I had a technichan tell me how to clean the system but have forgotten the formula.
     
  2. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    What does clean it mean?

    What have you done to troubleshoot the problem?

    Is it using salt?

    How old is it?

    Is there too much water in the salt tank?
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. softwateruser

    softwateruser New Member

    Joined:
    Apr 18, 2009
    1. I had a tech tell me you can remove all of the salt and put something like vinager in the brine tank, but I don't remember the formula, then regenerate. then when it's done go back to the salt.

    2. The only trouble shooting I did was to make sure the brine tank had salt and then I waited to make sure after regenerating that the salt level had gone down so I knew it was working. And tried regenerating manually.

    3. yes

    4. 9 years old

    5. the water is up about a forth or third of the tank.
     
  5. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    I've never heard of using vinegar in a softener. You'd need a lot, and I wouldn't do it.

    If the water level in the salt tank is higher than normal, that means the control valve isn't sucking salt water correctly. The usual cause is lose brine line connectors, a blocked injector and/or injector screen or a kinked/blocked drain line.
     
Similar Threads: brine softwater
Forum Title Date
Water Softener Forum, problems, installation and r 5000 SXT "Soft water refill for a cleaner brine tank" Apr 25, 2015
Water Softener Forum, problems, installation and r Max distance between Fleck 7000 valve and Brine tank? Mar 13, 2015
Water Softener Forum, problems, installation and r Kinetico Model 60, 1 tank now very loud during brine rinse Mar 10, 2015
Water Softener Forum, problems, installation and r Fleck 5600sxt overfilling brine tank Feb 11, 2015
Water Softener Forum, problems, installation and r Greenish fluid in brine tank Jan 4, 2015

Share This Page