air in my water system

Discussion in 'Pumps and Tanks Well Forum & Blog. Water is life.' started by scutter, Mar 20, 2013.

  1. scutter

    scutter New Member

    Joined:
    Mar 20, 2013
    Location:
    cornish, NH
    I have a shallow well with a pump/tank in my basement and it has an air problem. I replaced the suction line to the pump 3 or 4 years ago and thoiught the problem was solved but am still seeing the problem. Typically happens after doing laundrey. the pump loses suction and I have to re-prime, often several times. Foot valve is good. Could the pump be the culprit?
    Thanks
    Steve
     
  2. LLigetfa

    LLigetfa DIYer, not in the trades

    Joined:
    Feb 6, 2011
    Occupation:
    Information Technology
    Location:
    NW Ontario, Canada
    Sounds like the well is running dry.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. scutter

    scutter New Member

    Joined:
    Mar 20, 2013
    Location:
    cornish, NH
    thanks, have checked and it's full..
    S
     
Similar Threads: water system
Forum Title Date
Pumps and Tanks Well Forum & Blog. Water is life. Haul Water System Aug 3, 2016
Pumps and Tanks Well Forum & Blog. Water is life. Sand in water system after restart May 23, 2016
Pumps and Tanks Well Forum & Blog. Water is life. Can I Rework My Well Pump/pressure Tank System Now That I Don't Need It For House Water? May 4, 2016
Pumps and Tanks Well Forum & Blog. Water is life. How is so much air getting into our water system? Mar 27, 2016
Pumps and Tanks Well Forum & Blog. Water is life. At Wits end with water system Feb 2, 2016

Share This Page