air in my water system

Discussion in 'Pumps and Tanks Well Forum & Blog' started by scutter, Mar 20, 2013.

  1. scutter

    scutter New Member

    Joined:
    Mar 20, 2013
    Location:
    cornish, NH
    I have a shallow well with a pump/tank in my basement and it has an air problem. I replaced the suction line to the pump 3 or 4 years ago and thoiught the problem was solved but am still seeing the problem. Typically happens after doing laundrey. the pump loses suction and I have to re-prime, often several times. Foot valve is good. Could the pump be the culprit?
    Thanks
    Steve
     
  2. LLigetfa

    LLigetfa DIYer, not in the trades

    Joined:
    Feb 6, 2011
    Occupation:
    Information Technology
    Location:
    NW Ontario, Canada
    Sounds like the well is running dry.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. scutter

    scutter New Member

    Joined:
    Mar 20, 2013
    Location:
    cornish, NH
    thanks, have checked and it's full..
    S
     
Similar Threads: water system
Forum Title Date
Pumps and Tanks Well Forum & Blog Tiny house gravity fed water system.....low pressure Jan 17, 2015
Pumps and Tanks Well Forum & Blog New Water Storage System Jan 10, 2015
Pumps and Tanks Well Forum & Blog Advice on Plumbing 2500-gal Water Storage Tank into Existing Well System May 9, 2014
Pumps and Tanks Well Forum & Blog Need help with building a water softener system Apr 25, 2014
Pumps and Tanks Well Forum & Blog Water system noobie - How to prevent vacuum in tank Apr 8, 2014

Share This Page