Won`t build pressure...

Discussion in 'Pumps and Tanks Well Forum & Blog' started by hammy233, May 25, 2005.

  1. hammy233

    hammy233 New Member

    May 7, 2005
    Hello....just tonight I noticed my pump running continuously at 30psi, I turned off the switch, waited a couple of secs, turned switch back on and it built pressure back up to 50psi cutout,experimented a couple of times, ran water in sink until switch cut in same thing, we also hooked up a new washing machine tonight, a front load type, is this the culprit? I have a Jet Pump in my basement, and Wellxtrol 202Pro, a dug well, 18ft to water with 12ft of water. :(
  2. Gary Slusser

    Gary Slusser That's all folks!

    Aug 31, 2004
    Wherever I park the motorhome.
    I don't know if there is nothing wrong now or if there is.... When a jet pump won't build pressure, it is sucking air or there is blockage in the jet or something is sucked up against the inlet screen preventing water to get into the foot valve.

    If it builds 50 psi and shuts off, then it's wroking now but it maigh have the problem again.

    Quality Water Associates
  3. Sponsor

    Sponsor Paid Advertisement

Similar Threads: Won`t build
Forum Title Date
Pumps and Tanks Well Forum & Blog Help! Submersible well pump runs but won't build pressure over 30 psi! Nov 13, 2015
Pumps and Tanks Well Forum & Blog Jet pump slow to build pressure Aug 31, 2015
Pumps and Tanks Well Forum & Blog Well pump won't build up pressure Aug 23, 2015
Pumps and Tanks Well Forum & Blog Zoeller M98 M53 rebuild Jun 17, 2015
Pumps and Tanks Well Forum & Blog iron build up in a point driven well Jun 16, 2015

Share This Page