RO water smells like fish

Discussion in 'Water Softener Forum, problems, installation and r' started by vegashomes, May 13, 2011.

  1. vegashomes

    vegashomes New Member

    Messages:
    26
    My RO water has a fishy smell. I had low water pressure so I changed all the charcoal and sediment filters. Still had low pressure and found that the bladder in the tank had ruptured so put in a new tank. pressure came back but still smells fishy. I put in a new membrane and polishing filter and still smells bad.
  2. rjh2o

    rjh2o New Member

    Messages:
    75
    Location:
    Michigan
    Fishy smell

    Bacteria can cause many different types of odors. The system needs to be sterilized. Unfortunately I would suggest replacing all the filters, including membrane, so there is no change of re-contamination. www.softenerparts.com sells the sanitizing solution for this. You can use house hold bleach also.
    1. Turn incoming water off
    2. Open RO faucet and run all the water out of tank
    3. Remove all the filters and membrane
    4. Empty RO tank completely
    5. Add 1/2 teaspoon to each filter housing, reinstall housings with NO filters
    6. Turn the water back on until water comes out of RO faucet
    7. Shut the RO faucet off
    8. Let this sit for 10 minutes
    9. Flush the system completely of any residual bleach
    10. It helps to use latex gloves when installing filters to prevent contamination again
    11. Re-install all filters
    12. Flush 2 tanks of water at RO faucet
    This is recommended each time you change filters. It is very easy to re-contaminate the system with just bacteria from your hands, so use the latex gloves and wash hands thoroughly before changing any filters.
    RJ
  3. vegashomes

    vegashomes New Member

    Messages:
    26
    Thank you. Do I have to throw out the new RO membrane too?
  4. rjh2o

    rjh2o New Member

    Messages:
    75
    Location:
    Michigan
    Sorry to say so but yes I would for fear of re-contaminating the system. If the RO is more than 3 years old you may want to replace the capillary tube also.
    RJ
Similar Threads: water smells
Forum Title Date
Water Softener Forum, problems, installation and r Hot Water Smells Aug 18, 2011
Water Softener Forum, problems, installation and r Softener appears to be working, but no soft water Today at 5:21 PM
Water Softener Forum, problems, installation and r Installed Water Softener - Still Getting Water Spots Today at 6:51 AM
Water Softener Forum, problems, installation and r Water Softener Pre-Plumbed Prep Yesterday at 6:05 PM
Water Softener Forum, problems, installation and r Kinetico water softener and salty tasting water Aug 10, 2014

Share This Page