Please help -- culligan water softener problem

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by ADRamsey, Aug 11, 2005.

  1. ADRamsey

    ADRamsey New Member

    Joined:
    Feb 16, 2005
    We have a culligan mark 89 water conditioner that's about 10 years old and has always worked perfectly, until now. The last time we added salt, things just stopped. The unit seems to cycle (humming noise, water goes out the drain and into the brine tank) but the water is horrible. We have iron and iron bacteria, the taste and odor are awful and it's ruining my bathroom fixtures and we can't wash clothes. We've already taken down and cleaned the brine tank, which seemed to improve things slightly for a day or two, but now it's back to the same old thing; brown, cloudy water with a strong taste and smell. We can't get service in our rural area. Is there something else I should be doing? We've already checked for a salt bridge and we're convinced that's not the problem. Could a clogged line or something else cause this?
     
Similar Threads: Please help
Forum Title Date
Plumbing Forum, Professional & DIY Advice Urgent, Please Help! Island Drain/vent Installed Correctly? Yesterday at 3:26 PM
Plumbing Forum, Professional & DIY Advice What type of diverter is this??? Please Help!!! Mar 19, 2016
Plumbing Forum, Professional & DIY Advice Help with roughing in floor mount rear discharge toilet please Mar 13, 2016
Plumbing Forum, Professional & DIY Advice Impossible to find Shower Cartridge?? Help please! Mar 11, 2016
Plumbing Forum, Professional & DIY Advice Please help. Sewer gas smell only at night, only January-March Feb 28, 2016

Share This Page