Please help -- culligan water softener problem

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by ADRamsey, Aug 11, 2005.

  1. ADRamsey

    ADRamsey New Member

    Messages:
    4
    We have a culligan mark 89 water conditioner that's about 10 years old and has always worked perfectly, until now. The last time we added salt, things just stopped. The unit seems to cycle (humming noise, water goes out the drain and into the brine tank) but the water is horrible. We have iron and iron bacteria, the taste and odor are awful and it's ruining my bathroom fixtures and we can't wash clothes. We've already taken down and cleaned the brine tank, which seemed to improve things slightly for a day or two, but now it's back to the same old thing; brown, cloudy water with a strong taste and smell. We can't get service in our rural area. Is there something else I should be doing? We've already checked for a salt bridge and we're convinced that's not the problem. Could a clogged line or something else cause this?
Similar Threads: Please help
Forum Title Date
Plumbing Forum, Professional & DIY Advice please help! why is shower valve not centered? Oct 4, 2014
Plumbing Forum, Professional & DIY Advice Please help me identify kitchen sink issue Sep 10, 2014
Plumbing Forum, Professional & DIY Advice I'm fed up trying to get my p-trap and riser plumb. Please help me before I spontaneously combust! Sep 2, 2014
Plumbing Forum, Professional & DIY Advice Can someone help with my drain please? Aug 30, 2014
Plumbing Forum, Professional & DIY Advice Help please--fixed one leak, created another... Jul 27, 2014

Share This Page