Luxaire Furnace

Discussion in 'HVAC Heating & Cooling' started by Fudog, Apr 28, 2008.

  1. Fudog

    Fudog New Member

    Messages:
    28
    I have a luxaire furnace that has been working fine until today. The bathroom sink cold water hose burst and resulted in a small flood and the bathroom is right above the washroom where the furnace is and a little bit of water leaked down onto the top of the furnace.I pulled the cover off and wiped it with a paper towel. A little bit dripped down onto the gas valve where there is a small black plastic cover with 2 screws in it containing a circuit board and there is 2 wires connected to it ( black and yellow). The problem is furnace will light then go out after about 30 seconds. The flame sensor is very clean as I pulled it out and cleaned it again also ignitor is working fine.Any ideas as to what the problem might be? Thanks for listening.:eek:
  2. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Messages:
    22,319
    Location:
    New England
    The general advice I've heard is if a gas valve gets wet, replace it. See what the pros have to say.
Similar Threads: Luxaire Furnace
Forum Title Date
HVAC Heating & Cooling Luxaire Furnace Oct 20, 2013
HVAC Heating & Cooling Furnace fan works on AUTO but not on ON Dec 7, 2014
HVAC Heating & Cooling Forced Air Furnace Design, Who Can Do A Good Job? Nov 26, 2014
HVAC Heating & Cooling Run fan only on old gas furnace Nov 25, 2014
HVAC Heating & Cooling Roof Venting Condensing Gas Furnace Oct 21, 2014

Share This Page