Kinetico valve tune-up

Discussion in 'Water Softener Forum, problems, installation and r' started by TCox, Dec 4, 2009.

  1. TCox

    TCox New Member

    Messages:
    6
    Location:
    Loves Park, IL
    What a great forum! I'm newly registered, but I've been following the threads for over a week. I think the answeres, discussions and suggestions are fantastic. Now, on to my question: I've just moved into a home that has a Kinetico Model 60. I'm very handy and mechanically inclined, but unfamiliar with the workings of this softener. There is a Kinetico dealer/servicer only blocks away, but unwilling to help other than to send out a service rep. This is an older softener, but in pretty good condition. It used to be on well water, but is now on city service. The pre-filter had been neglected for an unknown amount of time. The previous owner had been using rock salt of the de-ice your sidewalk variety judging by the two inches of mud in the bottom of the brine tank. I changed the filters, cleaned the brine tank and float/valve, and manually cycled each tank several times in an effort to remove any dirt or clay left behind by the old brine. The water seems to be pretty soft and everything seems to be working fine, except that the drain drips constantly, nearly to the point of a steady stream. I suspect dirt or debris in the valve that closes the drain. Does anyone know if that is a rotary valve that may have a cut in the o-ring, or is it another type of mechanism. Am I looking for trouble if I take the valve head apart? I repair and restore old clocks for fun and it can't be much worse than that, or can it??

    Thanks guys!
  2. TCox

    TCox New Member

    Messages:
    6
    Location:
    Loves Park, IL
    Thanks for the help. I went home for lunch and the drip has become a steady stream, so I will attempt a repair this weekend. I wish I could get my hands on an exploded view or at least an IPL.
Similar Threads: Kinetico valve
Forum Title Date
Water Softener Forum, problems, installation and r Kinetico Model 60 recharging more often and using more salt than it used to Today at 7:51 AM
Water Softener Forum, problems, installation and r Maximum PSI intake for Kinetico 2175 Jul 9, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Salt taste in house water May 20, 2014
Water Softener Forum, problems, installation and r "Big picture" of Kinetico process available? May 11, 2014
Water Softener Forum, problems, installation and r Kinetico Mach Series Potassium not drawing Apr 18, 2014

Share This Page