Is it my thermostat?

Discussion in 'HVAC Heating & Cooling' started by cpio, Nov 6, 2009.

  1. cpio

    cpio New Member

    Messages:
    2
    Location:
    Michigan
    Having a continuous burn problem with my gas furnace. In a cycle, the following happens:
    1) Hear the relays click in the furnace.
    2) In about 20 seconds the 3 gas jets ignite and burn for about 30 seconds
    3) At this time the blower kicks on, and the jets turn off immediately.
    4) For the next 1.5 minutes the blower keeps going, and during this time
    the igniters turn on and glow for about 2 more times - but no gas.
    5) Finally, the blower steps up its speed considerably before shutting off.
    6) The furnace then won't come back on for about 20 minutes, unless the
    power is turned off and back on, or the digital thermostat is turned down
    then back up.
    What's also interesting is that the control board on the furnace is in default
    configuration which is 2 stage, yet the thermostat is wired for single stage.

    I've measured the voltage potential between the red & green, and the
    red & white. When the furnace starts the voltage drops to zero
    between the red & white as I'd expect, but is otherwise at about 25v.
    On the other hand, the voltage between the red & green is constantly
    at 25v regardless of what is going on.

    Any help wouid be appreciated.
Similar Threads: thermostat
Forum Title Date
HVAC Heating & Cooling Can this be used for "C" wire to the digital thermostat? Friday at 10:55 AM
HVAC Heating & Cooling Looking for simple programable one day thermostat Apr 10, 2014
HVAC Heating & Cooling Thermostat Wiring question Feb 14, 2014
HVAC Heating & Cooling Connecting the "Fan "Only" on Thermostat Dec 11, 2013
HVAC Heating & Cooling How to wire a new thermostat Nov 3, 2013

Share This Page