Culligan water softner continually recharges!

Discussion in 'Water Softener Forum, problems, installation and r' started by MommyDoes, Dec 28, 2012.

  1. MommyDoes

    MommyDoes New Member

    Joined:
    Dec 28, 2012
    Location:
    NY
    Hello Terry,
    I hope you can give some insight into this. I have an older culligan water conditioner model #4509 UL 646 (think its a Mark 89.) I just replaced the seals, (piston and valve) however had to use my old valve because the one that came with the kit was not for my unit.
    Anyhow the system started running non stop, I by passed it after 6hrs. Now the motor turns so I cant figure out why its doing this?
     

    Attached Files:

  2. Akpsdvan

    Akpsdvan In the Trades

    Joined:
    Dec 29, 2009
    Occupation:
    Business owner/service and sales
    Location:
    Alaska
    Is it that once it finishes a cycle it starts again?
    Or it will not stop at each point within a cleaning cycle?
    Micro switches or the white cam could be off or bad.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Culligan water
Forum Title Date
Water Softener Forum, problems, installation and r Please help: Culligan water softener Jul 10, 2014
Water Softener Forum, problems, installation and r Installing used Culligan water softener + Potassium tank Apr 21, 2014
Water Softener Forum, problems, installation and r Culligan Hi-Flow 3 water softener control issues Sep 30, 2013
Water Softener Forum, problems, installation and r Culligan Mrk89 not enough water in brine tank. Sep 12, 2013
Water Softener Forum, problems, installation and r Culligan Super S with yellow/brown water Aug 11, 2013

Share This Page