Clack water softener.

Discussion in 'Water Softener Forum, problems, installation and r' started by abcrobots, Feb 3, 2011.

  1. abcrobots

    abcrobots New Member

    Messages:
    3
    Location:
    Ontario, Canada
    Hi
    I am having a problem with my WS-1 clack softener.
    The problem is, I get no soft water out of the unit, and the brine tank is FULL to the top of water. It's like the unit isn't drawing anything out of the brine well during regen, but every time, it adds more to the tank, despite the float being buried in water, and the valve being closed.
    I took the float/valve assembly out of the tank, and blew in it to check to see if it was closing, and it seems to be. It's also not allowing water out (sucking) when the float is in the up position.
    I'm a bit of a newbie, but I'm adventurous, so if you guide me on the finer points of rebuilding that puppy, I'll give it my best.... That is, of course if that's what you think is required.....
    How is it supposed to work, anyway? what is supposed to be the sequence of operations?

    Thanks in advance!
  2. Gary Slusser

    Gary Slusser That's all folks!

    Then you probably have water flowing into the salt tank when it shouldn't be. The cause is the brine piston and seals leaking. So you replace the main and brine pistons and seals called the stack. To test that guess remove the brine line from the fitting on the control valve and watch to see if there is water flowing out the fitting after a minute or so. If there is that's your problem and it prevents any water from being sucked out of the salt tank during the Brining position and usually allows flow into the salt tank rather sucking any out.
  3. Tom Sawyer

    Tom Sawyer In the Trades

    Messages:
    3,137
    Location:
    Maine
    Isn't a major cause of that problem a cracked or loose fitting in the brine tank on the line?
  4. abcrobots

    abcrobots New Member

    Messages:
    3
    Location:
    Ontario, Canada
    THanks for the advice-
    Any idea whare I can buy the seals and pistons for this unit?
  5. abcrobots

    abcrobots New Member

    Messages:
    3
    Location:
    Ontario, Canada
    UPDATE:
    I took the brine line off the brine assembly, and there was no pressure or water in the line. I just wonder if the program is calling for too much time when refilling the brine tank?
    How do I check, what setting is that, and what should the setting be? I have set the float in the tank for as low as it will go, which is only about half-full in the brine tank. I suppose the setting will vary depending on the water pressure, ie. more pressure, less time is required to fill the tank?
    I have pretty high water pressure here, and the city is constantly screwing around with the settings.
  6. Gary Slusser

    Gary Slusser That's all folks!

    The Fill cycle is flow and time controlled.

    You do not set the salt dose by the height of the float, it is a safety float used to prevent water overflow onto the floor. It should be set as high as possible, just below the overflow elbow.

    You program the number of lbs in the Installer section of the programming and the instructions on how to get into that are in the manual; the Next and Down buttons simultaneously for 3 seconds IIRC. If it's not Down it's the Up button.

    Who did you buy this from that you don't know how to program it?

    BTW, I said to take the brine line off the control valve, not the brine assembly. It does make a difference becasue doing the 2310 valve end you have to watch the end of the brine line much longer because water drains out of it as you disconnect the line and you'll raise the end to watch and it takes awhile for the line to fill with water before it comes out.

    You should be able to buy parts from the company you bought the softener from; if they are still in business. If not , call email and fax Clack.
Similar Threads: Clack water
Forum Title Date
Water Softener Forum, problems, installation and r New Clack Based Water Softener Not Pulling Brine on Recharge Feb 8, 2013
Water Softener Forum, problems, installation and r Low flow from Clack WS1 water softener Apr 22, 2012
Water Softener Forum, problems, installation and r Help Confirm Clack WS1 settings after recent water test. Feb 28, 2011
Water Softener Forum, problems, installation and r How re-program new to me 1 cubic ft Clack based water softenerr Jan 31, 2011
Water Softener Forum, problems, installation and r Clack WS1 salty water problem Nov 4, 2009

Share This Page