Carrier 58RAV Error 12 "blower on after start up"

Discussion in 'HVAC Heating & Cooling' started by musicis, Jan 14, 2010.

  1. musicis

    musicis New Member

    Messages:
    8
    I have a "blower on after startup (115v or 24v)" error 12 going on. Came home to 55 degrees with cold air blowing. When I shut down the power for 15 minutes and restart. The unit right away starts the blower and thats it! No attempt to ignite at all. The blower just blows colds air and does not stop. Any suggestions on this would be great. I just need a fishing pole. Thanks Rick

    UPDATE: Interesting. Blower ran 90 seconds. Then code 33 starting blinking. Then the glow stick lit and flames. But that only lasted 3 minutes as the flames went out and it blinked 33 again. But a minute or so later the glow stick started and flames. This went on maybe 5 minutes and then cycled all over again. I did change the filter. It was dirty but it has been worst before. It appears that I have heat. Never looked at the furnace in action before. I assume it never cycled back to heat hence the 58 degrees when i got home. Maybe and hopefully it was just the filter. Thanks so much for the replies.
    Last edited: Jan 14, 2010
Similar Threads: Carrier 58RAV
Forum Title Date
HVAC Heating & Cooling Carrier A/C Not getting cold May 21, 2014
HVAC Heating & Cooling Carrier N Coil installation Mar 5, 2014
HVAC Heating & Cooling Carrier Furnace Rollout switch keeps tripping HELP! Feb 14, 2014
HVAC Heating & Cooling Replacing Carrier TSTATCCPRH01-B With Ecobee Smart Wiring Question Jan 22, 2014
HVAC Heating & Cooling Carrier heat pump code 82 - thermal lockout Oct 26, 2013

Share This Page