Aprilaire 600A won't turn on

Discussion in 'HVAC Heating & Cooling' started by mortal798, Oct 28, 2011.

  1. mortal798

    mortal798 New Member

    Messages:
    24
    Location:
    Pinckney, MI
    Hi everybody,

    I have an Aprilaire 600A, and just like the title says - it won't turn on. I have 24vAC at the 'R' and 'C' terminals in the controller. The water solenoid is hooked up to 'H' terminals. The outdoor temp sensor is hooked up to 'ODT.' And the unit is set up to use the call for heat from the t-stat to detect blower operation, so 'W/G' on the Aprilaire controller is hooked up to 'W' on the furnace board and 'Cf' on the controller is hooked up to Common on the furnace.

    Does it sound like my connections are correct? It won't even light up in 'Test/Reset' mode. Any ideas? Thanks in advance!
  2. mortal798

    mortal798 New Member

    Messages:
    24
    Location:
    Pinckney, MI
    Oh yeah, just another piece of info - it doesn't work with the manual resistor either...
  3. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,206
    Location:
    Houston, TX
    Is that a new install ?

    Did it ever work ?
  4. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Messages:
    22,051
    Location:
    New England
    The solonoids don't last forever...you can just replace that, if it's the problem. If it has 24vac across the input to the solonoid, but it hasn't turned on, it's probably that.
  5. mortal798

    mortal798 New Member

    Messages:
    24
    Location:
    Pinckney, MI
    It used to work, I turned it off for the summer. Then I removed the old furnace and replaced it. Once I reconnected the 600A, it wouldn't turn on. I have 24vAC at the controller, but the display doesn't light up - and it won't even go into test mode. I think I may have a bad controller.

    The furnace works like a million bucks, just that d#$* humidifier won't come on.
  6. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,206
    Location:
    Houston, TX
    The 2 H output terminals should have the 24VAC always-on transformer output winding is series with the solenoid,
    connected to them.

    Measuring from terminal H - H You should see 24VAC when the unit is not calling for humidity.
  7. mortal798

    mortal798 New Member

    Messages:
    24
    Location:
    Pinckney, MI
    Yes, and when the solenoid comes on all the voltage should drop. The solenoid coming on isn't the problem (well, it may be a problem later...), the controller doesn't come on to tell the solenoid to come on. The controller doesn't even light up in test mode.
Similar Threads: Aprilaire 600A
Forum Title Date
HVAC Heating & Cooling Wiring Help - Aprilaire 400 Jan 2, 2014
HVAC Heating & Cooling Need help with Aprilaire 400M Humidifier, cannot open Saddle valve for water Dec 13, 2013
HVAC Heating & Cooling Aprilaire 1710A Stand Alone Dehumidifier Jun 2, 2010
HVAC Heating & Cooling aprilaire humidifier Feb 17, 2009
HVAC Heating & Cooling Aprilaire 760 humidifier Feb 2, 2008

Share This Page