Appollo Heater - Does not blow hot air

Discussion in 'Water Heater Forum, Tanks' started by Pomah25, Dec 13, 2010.

  1. Pomah25

    Pomah25 New Member

    Joined:
    Dec 13, 2010
    Location:
    Chesapeake, VA
    How are you, hopefully i am posting this in the right place.

    I have an Apollo water heater, when i turned the heat on the other day, the air coming out of the vents is barely warm air. It heats the house, but takes forever and the heater is constantly running.

    I did some googling, and some of the things that i read said to change the air filter(done) and to turn the water temp up (done). The water temp is so hot, that when i have to turn hot water on i also have to run cold water just to be able to use without scalding myself. None of it seemed to help, the air coming out the ducts i still barely warm. Does anyone have any suggestions?

    My water heater is 50 gallons (same as originally installed)

    If i need to provide more info, just let me know what you need.
    Thank you so much in advance!
     
  2. Pomah25

    Pomah25 New Member

    Joined:
    Dec 13, 2010
    Location:
    Chesapeake, VA
    checked the temp coming out of the vents and its about 79.8 degrees, according to all the research i did it should be about 95 or so. Not sure what to do...

    It looks like the heating unit is made by First Co. out of Dallas Texas and Model number is 30VAq3 3DVAQ3. Any help would be greatly appreciated.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Appollo Heater
Forum Title Date
Water Heater Forum, Tanks 2015 water heater regulations Tuesday at 4:45 AM
Water Heater Forum, Tanks Water Heater will not stay lit Mar 20, 2015
Water Heater Forum, Tanks Water Heaters - Dodge, Chevy, Ford Mar 17, 2015
Water Heater Forum, Tanks High Pitched Noise from Gas Water Heater Mar 16, 2015
Water Heater Forum, Tanks Help replacing old Apollo Hydroheater Mar 16, 2015

Share This Page