Sump pump troubles

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by Dave3103, Oct 30, 2008.

  1. Dave3103

    Dave3103 New Member

    Joined:
    Oct 30, 2008
    Hello All,

    Just looking for some advice.
    I have installed a "sump buddy" to clear the sump water during power outages. It's just a float switch that allows city water to drive a venturi pump. The problem I'm having is when the float valve is activated the output is no more that a low flowing dribble, if I hold the float valve open and close the inlet ball valve, then open the ball valve - the output is great. This only works when I manually actuate the inlet water supply. I opened the valve assembly and there is nothing unusual, the body of the valve is exactly the same as a solenoid style valve.
    I know I should just take the thing back but once this thing is installed it's a real pain to take apart, and I cannot find anything wrong. Possible high pressure locking up the valve?
     
Similar Threads: Sump pump
Forum Title Date
Plumbing Forum, Professional & DIY Advice Sump pump drain pipe Thursday at 4:29 PM
Plumbing Forum, Professional & DIY Advice Sump Pump found non-functional during inspection, switch is OFF and no signs of flood in bsmnt... Aug 22, 2017
Plumbing Forum, Professional & DIY Advice Sump pump help Jul 26, 2017
Plumbing Forum, Professional & DIY Advice Sump Pump "built in" check valves? Home inspector needing more info Jul 12, 2017
Plumbing Forum, Professional & DIY Advice Sump Pump gurgles when radon system turned on Jun 8, 2017

Share This Page